Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

release building problem.
Started by kaeguree Mar 07 2020 01:19 PM

10 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

kaeguree

[GLOBAL: userInfoPane.html]
kaeguree
  • Enthusiast

  • 55 posts
  • Corona SDK

I recently created new provisioning profile

 

Its form seems to be different from that was from 'iphone distribution' to 'apple distribution'.

 

when i build with Apple development provision profile, there is no problems.

 

but when I build with Apple distribution, there is no .ipa , instead   .app is created.

 

I need .ipa to upload to appstore.

 

What should i do?

 


  • pixec likes this

[TOPIC: post.html]
#2

troylyndon

[GLOBAL: userInfoPane.html]
troylyndon
  • Contributor

  • 641 posts
  • Corona SDK

I have the same problem.



[TOPIC: post.html]
#3

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Corona Geek

  • 1,415 posts
  • Corona SDK

Last time I check you can still create an old certificate type. I just created one about 3 days ago. Just select the old type (green in the picture) and not the new type (red in the picture).

 

Attached File  certspic.png   100.21KB   2 downloads



[TOPIC: post.html]
#4

pixec

[GLOBAL: userInfoPane.html]
pixec
  • Contributor

  • 207 posts
  • Corona SDK

Can someone confirm if agramonte’s solution works?

[TOPIC: post.html]
#5

kaeguree

[GLOBAL: userInfoPane.html]
kaeguree
  • Enthusiast

  • 55 posts
  • Corona SDK

I guess this is corona side problem.

the day before yesterday, my development provision worked well.

but now, that has the same problems.



[TOPIC: post.html]
#6

pixec

[GLOBAL: userInfoPane.html]
pixec
  • Contributor

  • 207 posts
  • Corona SDK

Did you update Corona in the last few days? Seems odd that Corona would have made something. Agramonte’s fix doesnt work for you then?

[TOPIC: post.html]
#7

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Corona Geek

  • 1,415 posts
  • Corona SDK

I just built with version 3575 and i can confirm that I can build an ipa instead of an app if I use the iOS certificates and not the new ALL certificates.

 

Here is what my certificates look like. Again "green" are the old "ipa" certificates. They expire in a year so you see I created 1 on Feb 11 and the other about a year ago.

 

Attached File  cert2.png   65.84KB   0 downloads



[TOPIC: post.html]
#8

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Corona Geek

  • 1,415 posts
  • Corona SDK

Notice also that the profile for the app I just built listed the old certificate type and not the new type:

 

Attached File  cert3.png   49.87KB   0 downloads



[TOPIC: post.html]
#9

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,680 posts
  • Enterprise

Corona does not yet support the "All apps" profiles. 

 

Please do not create threads point to existing threads. It just creates extra work for everyone. If your problem is the same, use the same thread. If your problem is different, use a different thread. 

 

I have deleted the "Pointer" thread.

 

Rob


  • Gil44liG likes this

[TOPIC: post.html]
#10

kaeguree

[GLOBAL: userInfoPane.html]
kaeguree
  • Enthusiast

  • 55 posts
  • Corona SDK

I'm sorry for bothering.

After change my certification, all works well.

[TOPIC: post.html]
#11

troylyndon

[GLOBAL: userInfoPane.html]
troylyndon
  • Contributor

  • 641 posts
  • Corona SDK

@agramonte, thank you. Your solution works.

@Rob and @Vlad, I sincerely apologize for the strong tone of my concern about this.




[topic_controls]
[/topic_controls]