Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Notarization no longer works? I've posted this in the Mac section but got no attention.
Started by tameem50 Feb 20 2020 12:18 PM

- - - - -
11 replies to this topic
mac corona notarization plugins
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

tameem50

[GLOBAL: userInfoPane.html]
tameem50
  • Contributor

  • 126 posts
  • Corona SDK

This was working up until a few weeks ago.  I'm following the same steps I always did and now I'm getting these errors..  Anyone know some steps to resolve?

https://i.imgur.com/nWkm2Lt.png

 


[TOPIC: post.html]
#2

Quantumwave

[GLOBAL: userInfoPane.html]
Quantumwave
  • Contributor

  • 135 posts
  • Corona SDK

Are you using the latest daily build?



[TOPIC: post.html]
#3

tameem50

[GLOBAL: userInfoPane.html]
tameem50
  • Contributor

  • 126 posts
  • Corona SDK

Are you using the latest daily build?

 

I'm on Version 2020.3574 (2020.2.10)



[TOPIC: post.html]
#4

Quantumwave

[GLOBAL: userInfoPane.html]
Quantumwave
  • Contributor

  • 135 posts
  • Corona SDK

See if the latest daily build makes a difference. Also, I use SD Notarize to simplify things:

 

https://latenightsw.com/sd-notary-notarizing-made-easy/

 

It may point out issues for you.

 

Dave



[TOPIC: post.html]
#5

tameem50

[GLOBAL: userInfoPane.html]
tameem50
  • Contributor

  • 126 posts
  • Corona SDK

See if the latest daily build makes a difference. Also, I use SD Notarize to simplify things:

 

https://latenightsw.com/sd-notary-notarizing-made-easy/

 

It may point out issues for you.

 

Dave

 

so your tool got me a lot closer.  just one error left now.  the rest of the errors went away ..  so close!
 

{
  "logFormatVersion": 1,
  "jobId": "e888c3da-f7a6-40bc-bee4-71b4816ac31a",
  "status": "Invalid",
  "statusSummary": "Archive contains critical validation errors",
  "statusCode": 4000,
  "archiveFilename": "Super_Orbit.zip",
  "uploadDate": "2020-02-20T23:42:29Z",
  "sha256": "1fb17ccf5e98c80f5fd29b2065e35ab7049fbe27a67a2cd5c84597db9a984dd0",
  "ticketContents": null,
  "issues": [
    {
      "severity": "error",
      "code": null,
      "path": "Super_Orbit.zip/Super Orbit.app/Contents/Plugins/plugin_bit.dylib",
      "message": "The binary uses an SDK older than the 10.9 SDK.",
      "docUrl": null,
      "architecture": "x86_64"
    }
  ]
}


[TOPIC: post.html]
#6

Quantumwave

[GLOBAL: userInfoPane.html]
Quantumwave
  • Contributor

  • 135 posts
  • Corona SDK

Are these checkboxes checked?

 

[  ]  Don't sign enclosures

[  ]  Process script applets only

[  ]  Disable library validation

 

Play around with different combinations and see if the error goes away.



[TOPIC: post.html]
#7

tameem50

[GLOBAL: userInfoPane.html]
tameem50
  • Contributor

  • 126 posts
  • Corona SDK

Are these checkboxes checked?

 

[  ]  Don't sign enclosures

[  ]  Process script applets only

[  ]  Disable library validation

 

Play around with different combinations and see if the error goes away.

 

I've been playing with them..  I notice that the process script applet only wont allow me to select my game.app file?  any idea what that one does or how i should use it?



[TOPIC: post.html]
#8

Quantumwave

[GLOBAL: userInfoPane.html]
Quantumwave
  • Contributor

  • 135 posts
  • Corona SDK

See the descriptions on the SD Notary page. I believe that checkbox is for AppleScript applets only.



[TOPIC: post.html]
#9

tameem50

[GLOBAL: userInfoPane.html]
tameem50
  • Contributor

  • 126 posts
  • Corona SDK

See the descriptions on the SD Notary page. I believe that checkbox is for AppleScript applets only.

 

ah okay..  when i choose my app using that it tells me it's not an apple script applet.  So.. guess i cant use that one.  I've used the other options and I'm just stuck with that bit plugin failing.  So close  :o



[TOPIC: post.html]
#10

tameem50

[GLOBAL: userInfoPane.html]
tameem50
  • Contributor

  • 126 posts
  • Corona SDK

my xcode version is slightly out of date.  does that matter?



[TOPIC: post.html]
#11

Quantumwave

[GLOBAL: userInfoPane.html]
Quantumwave
  • Contributor

  • 135 posts
  • Corona SDK

my xcode version is slightly out of date.  does that matter?

 

 

Possibly, I always update to the latest version.

 

Btw, if you're not using the bit plugin for heavy computation frequently, you can try one of the pure Lua implementations if this error won't go away:

 

http://lua-users.org/wiki/BitwiseOperators



[TOPIC: post.html]
#12

tameem50

[GLOBAL: userInfoPane.html]
tameem50
  • Contributor

  • 126 posts
  • Corona SDK

Possibly, I always update to the latest version.

 

Btw, if you're not using the bit plugin for heavy computation frequently, you can try one of the pure Lua implementations if this error won't go away:

 

http://lua-users.org/wiki/BitwiseOperators

 

It's part of a library im using.. i guess i can see how much its being used in the source but im wary of messing with the library since its not my code.  thanks for all your help btw




[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: mac, corona, notarization, plugins