Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]

Problem with InApp Purchases on iOS 13.3 (iPadPro)
Started by d.mach Jan 22 2020 01:55 AM

2 replies to this topic
iap problem ios
[TOPIC: post.html]


[GLOBAL: userInfoPane.html]
  • Contributor

  • 974 posts
  • Corona SDK

I just have updated an app and wanted to test the InApp purchases.

The price is loaded and shown correctly, so the store seems to work fine. I am locked in with a normal Apple ID AND also have entered a valid tester sandbox ID in the iPad Pro settings. In the game I am asked for entering the password for the sandbox ID. (After I have clicked on an IAP produkt). Now I enter the correct PW and it is not accepted. I then have tried to enter my "normal" PW for the normal Apple ID which then was accepted and the product confirmation purchase window was shown BUT nothing else! Which means I never get to the purchase code inside the listener... I did not reach event.transaction.state == "purchased"


What is going on here?


I am using Corona 3528 with store = require( "store" ) and xCode 10.3 with an iPadPro I just have updated to version 13.3 after which this problem occured.


How can I fix this and make sandbox tests working again while making sure older iOS versions also work fine!?


Any help welcome!


[TOPIC: post.html]


[GLOBAL: userInfoPane.html]
  • Contributor

  • 974 posts
  • Corona SDK

I'll try to make this strange problem visible:


(Sorry some of the screens are in German)


1. This popup is shown when I click on an IAP product for purchasing it:

Attached File  Sample_1.jpg   33.96KB   0 downloads


I then can click "Kaufen" which means "Buy it".

So I do...


2. When I click on it I get this screen popup now:

Attached File  Sample_2.jpg   41.66KB   0 downloads


As you can see I am in sandbox mode and am asked to enter the PW for my sandbox tester account.

Doing so fails!!! The PW is not working!

I then tried to use my normal Apple ID PW here and it worked and another popup tells me this BUT the purchase is not active (because the code for the transaction listener "purchased" state is not reached!)


This popup automatically means I can not purchase anything.


BUT after waiting for about three minutes this popup automatically closes!!! And instead the following one is shown:


3. This is shown after about 3 minutes:

Attached File  Sample_3.jpg   39.56KB   0 downloads


I get asked the same question for my sandbox tester account PW and when now entering it ... IT WORKS!


5. The purchase is detected correctly

Attached File  Sample_4.jpg   84.67KB   0 downloads


Can anybody tell me what is happening here?


Is this now happening to all users trying to purchase something in my game when they are using iOS 13.3 ?


Is this maybe only a problem with sandbox mode / testing?


[TOPIC: post.html]


[GLOBAL: userInfoPane.html]
  • Corona Geek

  • 1,057 posts
  • Corona Staff

Sandbox is sometimes finicky like that. No, it does not happen to live users. It is can be rather frustrating to test IAPs on iOS, because apple does  not give a way to test against real environment. You can try uploading to the TestFlight, and test  your IAPs when downloaded through it.


Also tagged with one or more of these keywords: iap, problem, ios