Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

admob plugin makes app quit immediately on launch
Started by Dodo Software Jan 15 2020 02:27 PM

1 reply to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

Dodo Software

[GLOBAL: userInfoPane.html]
Dodo Software
  • Observer

  • 7 posts
  • Corona SDK

In my build.settings I have the following plugins

	plugins =
	{
		["plugin.admob"] =
		{
                   publisherId = "com.coronalabs"
		},

		["plugin.notifications.v2"] =
		{
	           publisherId = "com.coronalabs"
		},
	},

When I build the app and run on a physical device, The application quits immediately.

I only put them in my build.settings. No reference to them in any of my scenes.

 

When I remove those plugins from my build.settings the app works fine on the physical device.

 

 

Corona build Version 2020.3567 (2020.1.9)

Can someone check this ?

 



[TOPIC: post.html]
#2

colinmorgan

[GLOBAL: userInfoPane.html]
colinmorgan
  • Enthusiast

  • 40 posts
  • Corona SDK

A while back AdMob started requiring that you have your AdMob App ID in the build.settings. https://goo.gl/fQ2neu

Do you have the following in your Android Section?

android =
{
	applicationChildElements =
        {
            [[
                <meta-data android:name="com.google.android.gms.ads.APPLICATION_ID"
                    android:value="ca-app-pub-xxxxxxxxxxxxxxxx~yyyyyyyyyy"/> --Your app ID goes here.
            ]],
        },
},

 




[topic_controls]
[/topic_controls]