Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

ERROR: Build Failed on Corona latest builds
Started by usmanmughal.uog Jan 11 2020 02:01 AM

- - - - -
16 replies to this topic
build failed ipa server http error xmlrpc
[TOPIC CONTROLS]
This topic is locked This topic is locked
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

usmanmughal.uog

[GLOBAL: userInfoPane.html]
usmanmughal.uog
  • Enthusiast

  • 78 posts
  • Corona SDK

Hi @Rob,

Is there anything updated/changed about the build process? I'm getting this error since yesterday. Here is console error I'm getting.
 

Building iOS app for xxxxx@xxxx.com with 2019.3567
Using custom build id from app bundle: 00000 (AppSettings.lua)
Note: debug info is not being stripped from application (settings.build.neverStripDebugInfo = true)
ERROR: XMLRPC: The operation couldn’t be completed. (HTTP error 413.)
ERROR: build failed

There was a problem completing the build on the server
iOS build failed (11) after 5 seconds
ERROR: Build Failed: ERROR: build failed

There was a problem completing the build on the server 

Let me know if anything need to fixed on my side. Thanks.

Usman Mughal
 



[TOPIC: post.html]
#2

usmanmughal.uog

[GLOBAL: userInfoPane.html]
usmanmughal.uog
  • Enthusiast

  • 78 posts
  • Corona SDK

I noticed after some tests, if the project size is small, build generate IPA successfully.



[TOPIC: post.html]
#3

Dodo Software

[GLOBAL: userInfoPane.html]
Dodo Software
  • Observer

  • 11 posts
  • Corona SDK

Can you share your build.settings file.

I have a similar issue when I include admob plugin or notification plugin.



[TOPIC: post.html]
#4

usmanmughal.uog

[GLOBAL: userInfoPane.html]
usmanmughal.uog
  • Enthusiast

  • 78 posts
  • Corona SDK

It's not the issue with plugins. My thought is, issue is with project size, as error code 413(payload too large) is related to request size.

Ref: https://developer.mozilla.org/en-US/docs/Web/HTTP/Status/413



[TOPIC: post.html]
#5

Aarbron

[GLOBAL: userInfoPane.html]
Aarbron
  • Contributor

  • 200 posts
  • Corona SDK

I agree that it's not a plugins issue.

 

Even if I remove all the plugins I still get the same error.

 

The ipa I'm trying to make will be less than 20mb.



[TOPIC: post.html]
#6

gongalf

[GLOBAL: userInfoPane.html]
gongalf
  • Observer

  • 12 posts
  • Corona SDK

I got the same error. I removed all the plugins too and I get the error again. If I create an empty project, it builds OK. 

 

What can we do?



[TOPIC: post.html]
#7

Mike Hempfling

[GLOBAL: userInfoPane.html]
Mike Hempfling
  • Contributor

  • 268 posts
  • Corona SDK

I get the same 413 error.

 

When I remove some of my LUA files I can get it to build so I think it has something to do with the amount of content in the files. I have been able to build and deploy this app in the past so I know the code is good.



[TOPIC: post.html]
#8

Studycat2

[GLOBAL: userInfoPane.html]
Studycat2
  • Enthusiast

  • 92 posts
  • Corona SDK

I'm getting same error with both Corona 3474 and 3531. My IPA is around 200MB.



[TOPIC: post.html]
#9

Viktor Mirzoyan

[GLOBAL: userInfoPane.html]
Viktor Mirzoyan
  • Observer

  • 21 posts
  • Corona SDK

I'm also facing this issue.



[TOPIC: post.html]
#10

info0829

[GLOBAL: userInfoPane.html]
info0829
  • Observer

  • 8 posts
  • Corona SDK

mee too!!!!



[TOPIC: post.html]
#11

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,622 posts
  • Enterprise

Our team is looking into this. It seems to be related to the outage we had on Friday. That 413 error started showing up for some people after that incident.

 

Rob



[TOPIC: post.html]
#12

Aarbron

[GLOBAL: userInfoPane.html]
Aarbron
  • Contributor

  • 200 posts
  • Corona SDK

Everything seems to be back to normal.

 

Rob, could you verify it?



[TOPIC: post.html]
#13

Mike Hempfling

[GLOBAL: userInfoPane.html]
Mike Hempfling
  • Contributor

  • 268 posts
  • Corona SDK

@Rob

 

Builds are working for me again so I assume that Corona fixed the issue.



[TOPIC: post.html]
#14

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,622 posts
  • Enterprise

The system admin team feels they have the 413 problem solved. Let me know if anyone is still getting the error.

 

Rob



[TOPIC: post.html]
#15

andavidosp

[GLOBAL: userInfoPane.html]
andavidosp
  • Observer

  • 29 posts
  • Corona SDK

Hi @Rob

 

I am getting nil on admob ads since i renewed my subscription on January 14. I don't know if it has something to do with the outage?

 

This is the responde that i am getting: event name: adsRequest envent phase: init event response: nil

 

Thanks.



[TOPIC: post.html]
#16

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,622 posts
  • Enterprise

I don't believe that's related, but it could be. 

 

Rob



[TOPIC: post.html]
#17

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,622 posts
  • Enterprise

Please move all discussions about the current server outage to this thread:

 

https://forums.coronalabs.com/topic/76957-use-this-thread-is-the-build-server-down/

 

Thanks

Rob




[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: build failed, ipa, server, http error, xmlrpc