Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

USE THIS THREAD: Is the Build Server Down?
Started by bayudsava Jan 10 2020 06:59 AM

28 replies to this topic
[TOPIC CONTROLS]
Page 1 of 2 1 2
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

bayudsava

[GLOBAL: userInfoPane.html]
bayudsava
  • Observer

  • 2 posts
  • Corona SDK

I keep getting Gateway Timeout when compiling for Android.
It's day 2 right now.

Is it just my Corona or is it the server?



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,539 posts
  • Enterprise

We had some errors earlier today (starting around 3am ET). I'm not sure what time it resolved itself or if it's fully resolved yet, but I just did builds for iOS and Android and they seemed normal. 

 

Rob



[TOPIC: post.html]
#3

i_i_i

[GLOBAL: userInfoPane.html]
i_i_i
  • Observer

  • 9 posts
  • Corona SDK

I have been getting Build Failed; HTTP error 504 frequently for the past several days.



[TOPIC: post.html]
#4

i_i_i

[GLOBAL: userInfoPane.html]
i_i_i
  • Observer

  • 9 posts
  • Corona SDK

ERROR: XMLRPC: The operation couldn’t be completed. (HTTP error 504.)
Jan 15 04:25:26.712 ERROR: build failed
                    
                    The operation couldn’t be completed. (HTTP error 504.)



[TOPIC: post.html]
#5

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,539 posts
  • Enterprise

Our server issues are still ongoing. They have been stable for the last 6 hours, but what ever is triggering it, could come back. Please be patient and try again laster. Our team is working to find the root cause of it.

 

Rob



[TOPIC: post.html]
#6

guy.stockwell

[GLOBAL: userInfoPane.html]
guy.stockwell
  • Contributor

  • 105 posts
  • Corona SDK

build for IOS successful. Android failed

FAILURE: Build failed with an exception.
 
* Where:
Build file '/private/var/folders/1_/k18c3y356_l9dypldfd0xfg40000gp/T/CLtmpwTEYQR/template/app/build.gradle.kts' line: 467
 
* What went wrong:
Not Found
 
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
 
* Get more help at https://help.gradle.org
 
BUILD FAILED in 14s


[TOPIC: post.html]
#7

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,539 posts
  • Enterprise

This problem is likely going to continue. We have not found the root cause yet and are making our best effort to solve it. The only advice is to try back periodically.

 

Rob


  • Michael Flad likes this

[TOPIC: post.html]
#8

stalxerhd

[GLOBAL: userInfoPane.html]
stalxerhd
  • Observer

  • 23 posts
  • Corona SDK

Hi, Rob! Any news about Build Server availability?


  • anna.krepchenko likes this

[TOPIC: post.html]
#9

carloscosta

[GLOBAL: userInfoPane.html]
carloscosta
  • Contributor

  • 674 posts
  • Corona SDK

This problem is likely going to continue. We have not found the root cause yet and are making our best effort to solve it. The only advice is to try back periodically.

 

Rob

 

My advice is the opposite. All stop trying to make builds, and let Corona try to discover/correct the problem. Come back in forum to check when it's ready. I bet all programmers right now are flooding resquests to make builds (I was one of them) not helping the problem.



[TOPIC: post.html]
#10

SGS

[GLOBAL: userInfoPane.html]
SGS
  • Corona Geek

  • 2,131 posts
  • Corona SDK

http://status.coronalabs.com/


  • pixec likes this

[TOPIC: post.html]
#11

rishibhat

[GLOBAL: userInfoPane.html]
rishibhat
  • Observer

  • 3 posts
  • Corona SDK

fwiw, I've had no problems building for Android last night (1/16) and early this morning (1/17).



[TOPIC: post.html]
#12

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,539 posts
  • Enterprise

Let me try and explain what’s happening.
 
But first, I’ve not gotten an update today. All services seem to be functional at this point. This is basically what I posted in Slack yesterday. Nothing has changed.
 
We have a sever known as developer.coronalabs.com. It is our main user database. It’s where authorizations are (for those who remember when we allowed only two authorized devices). It’s where we used to turn on Enterprise licenses. Self-hosted plugins are there and a bunch of other stuff. But more importantly this is where all logins happen. This database also has other bits, like when you sign up for a new account you’re registered and there are tie-ins to the website and it also drives forum logins, the name that shows in the forums and a bunch of other stuff. I suspect (I don’t have access to our full architecture) that the forum database may be on the same server. If this server doesn’t work, pretty much nothing is going to work.
 
Servers like Marketplace are running on a totally different server. Logins should be tied to developer, but I suspect that because cookies keep you logged in, it doesn’t have to hit developer that often. Plugin licensing is handled through the marketplace (except for self-hosted plugins).
 
Now, we have not found what’s causing developer to stop responding. We know that some of the server worker processes just stop running. The database is healthy. The web servers are healthy. We have gone down a lot of rabbit holes trying to find the root cause, but nothing so far is showing up. We thought we had it solved on Friday. One of the things we tried to fix created a reverse proxy problem which turned into the 413 error that iOS developers saw over the weekend. We got that solved, but now the developer problems are showing up sometime in the morning (east coast USA time) and magically clearing up sometime in the afternoon. But that is a vague general pattern and I don’t think we can really draw anything from it (because I’ve seen www/forums drop offline during evening hours.)
 
We are trying to bring in a specialist to give us a fresh set of eyes and see if we can find the root cause.I wish I had more of an updated. We know how frustrating this is. We are putting our best effort forward to solve it.

 

Now today's outage seemed to follow the same time frame. I don't have exact times that it goes down and there is some variability on when it comes back and then there are other sporadic outages. I've asked the server admins to look at background jobs that may be starting at a particular time and see if something there is amiss. Sadly I don't have visibility to go look at those things myself. I'm waiting on my next update from them.

 

Rob


  • OlinaChang likes this

[TOPIC: post.html]
#13

anna.krepchenko

[GLOBAL: userInfoPane.html]
anna.krepchenko
  • Observer

  • 9 posts
  • Corona SDK

IOS build failing now
error: There was a problem linking the app. 
https://pastebin.com/BJswwZ6B



[TOPIC: post.html]
#14

stalxerhd

[GLOBAL: userInfoPane.html]
stalxerhd
  • Observer

  • 23 posts
  • Corona SDK

Just successfully build my project.



[TOPIC: post.html]
#15

colinmorgan

[GLOBAL: userInfoPane.html]
colinmorgan
  • Enthusiast

  • 40 posts
  • Corona SDK

Rob,

Thank you for the rundown.

My experience today (Saturday, Jan 18) is that Pingdom is reporting 100% uptime for Build 2.0, and I was able to build for Android, no problem. Unfortunately, I'm still getting a "Problem linking the app" error when I try to build for iOS.

Fingers crossed the problem gets sorted out soon!



[TOPIC: post.html]
#16

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,539 posts
  • Enterprise

@anna.krepchenko, it looks like you're trying to build to a folder in the same folder as your project. This is generally not recommended. Please output your build to a folder outside your project and remove the .build folder from your project folder.

 

It would also be helpful if people having build issues for iOS share your build.settings.

 

Rob



[TOPIC: post.html]
#17

anna.krepchenko

[GLOBAL: userInfoPane.html]
anna.krepchenko
  • Observer

  • 9 posts
  • Corona SDK

@Rob i found build is ok, when remove firebase analytics from the build.settings
seems its smth with analytics again. Worked 2 days ago=(



[TOPIC: post.html]
#18

o.jacek

[GLOBAL: userInfoPane.html]
o.jacek
  • Observer

  • 29 posts
  • Corona SDK

I can confirm that deleting firebase plugin from my projects fixes problem with iOS build (it was working couple days ago).



[TOPIC: post.html]
#19

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,539 posts
  • Enterprise

In a couple of other threads, Scott said he patched the various firebase plugins. You might want to try again.

 

Rob



[TOPIC: post.html]
#20

gongalf

[GLOBAL: userInfoPane.html]
gongalf
  • Observer

  • 8 posts
  • Corona SDK

Android and iOS build is failing now (it gets hang during authorizing build).



[TOPIC: post.html]
#21

oddstream

[GLOBAL: userInfoPane.html]
oddstream
  • Observer

  • 1 posts
  • Corona SDK

Android build was working yesterday, but not at all today :(. Sympathy for the Corona peeps must be pulling each other's hair out by now.

 

13:29:22.645  HTTP/1.1 504 Gateway Time-out
13:29:22.645  Server: nginx/1.17.7
13:29:22.645  Date: Mon, 20 Jan 2020 12:09:26 GMT
13:29:22.645  Content-Type: text/html
13:29:22.645  Content-Length: 167
13:29:22.645  Connection: keep-alive


[TOPIC: post.html]
#22

colinmorgan

[GLOBAL: userInfoPane.html]
colinmorgan
  • Enthusiast

  • 40 posts
  • Corona SDK

Build server's down again:

http://status.coronalabs.com/



[TOPIC: post.html]
#23

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,539 posts
  • Enterprise

And we are trying to find the problem.  

 

Rob



[TOPIC: post.html]
#24

pbozzone0

[GLOBAL: userInfoPane.html]
pbozzone0
  • Observer

  • 28 posts
  • Corona SDK

So far, apparently, the server is not responding and it is not possible to compile an apk. Please urgent solution!


[TOPIC: post.html]
#25

shashwat

[GLOBAL: userInfoPane.html]
shashwat
  • Enthusiast

  • 55 posts
  • Corona SDK

We've practically not been able to build for over a week now. Would it help at all if some users could come together and contribute for new hardware if that helps the current situation and provides a more reliable option going forward? Many of us here have businesses that rely on Corona Products and this situation is obviously very undesirable and I'm sure we could help if your team would accept it. 


  • Dr.Klaus and gongalf like this


[topic_controls]
Page 1 of 2 1 2
 
[/topic_controls]