Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Got Error trying to build app
Started by hariton1500 Dec 25 2019 10:38 PM

6 replies to this topic
build error 2019.3564
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

hariton1500

[GLOBAL: userInfoPane.html]
hariton1500
  • Observer

  • 5 posts
  • Corona SDK

Got errors trying to build my app on Corona 2019.3564, but on official reliese no errors.

including logs....

https://pastebin.com/vUbTAvu2

 

 



[TOPIC: post.html]
#2

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Corona Geek

  • 1,031 posts
  • Corona Staff

Install java 1.8 and use latest daily build.

[TOPIC: post.html]
#3

hariton1500

[GLOBAL: userInfoPane.html]
hariton1500
  • Observer

  • 5 posts
  • Corona SDK

java version "1.8.0_231"
Java™ SE Runtime Environment (build 1.8.0_231-b11)
Java HotSpot™ Client VM (build 25.231-b11, mixed mode, sharing)
 

build.settings

https://pastebin.com/Y5aCRnak

 

build logs

https://pastebin.com/qfG6xemZ



[TOPIC: post.html]
#4

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Corona Geek

  • 1,031 posts
  • Corona Staff

It picks up wrong Java. Can you uninstall or delete other JDK/JRE?

 

> Detected Java version: 1.6 in: C:\Program Files\Java\jdk-13.0.1

you should only have 1.8, not 13.



[TOPIC: post.html]
#5

hariton1500

[GLOBAL: userInfoPane.html]
hariton1500
  • Observer

  • 5 posts
  • Corona SDK

Corona demands JDK to build apps. JDK 13.0.1 is the latest JDK. I dont undestand what to do. 

I see that removing notification plugin from build.settings goes to succesfull building. But I need notifications in my app (((

plugins = {  

       ['plugin.ui_framework'] = {publisherId = 'com.skyjoy'},
       ['plugin.app_framework'] = {publisherId = 'maciej.czekala'},
       --['plugin.notifications.v2'] = {publisherId = 'com.coronalabs'},
 
    }


[TOPIC: post.html]
#6

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Corona Geek

  • 1,031 posts
  • Corona Staff

Use JDK 1.8. Not 18. Android does not fully support JDK 13.

Build system used in Android, Gradle 5, does not support JDK 13. Please, use JDK 1.8



[TOPIC: post.html]
#7

hariton1500

[GLOBAL: userInfoPane.html]
hariton1500
  • Observer

  • 5 posts
  • Corona SDK

I did what you recomend, but got build errors when use notification plugin:

 

https://pastebin.com/0i4TeDDj




[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: build error, 2019.3564