Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

apple-iap problem. my products return as invalid
Started by baykalsarioglu Dec 21 2019 12:21 PM

2 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

baykalsarioglu

[GLOBAL: userInfoPane.html]
baykalsarioglu
  • Observer

  • 16 posts
  • Corona SDK

Hi there. I have a working game on the AppStore. It is old, but everything works fine on this old version.

 

Today, I wanted to update my game, and I noticed that for monetization, I had to switch to apple-iap. I updated the code with apple-iap, but now, my in-app purchase products return as invalid. The older version on the AppStore works fine, I can see the in-app purchases in the old version. 

 

Edit: I tried everything, profiles, certificates... Product Ids are correct, IAPs are approved. Somehow, with the new apple-iap LoadProducts returns all products as invalid products. 

 

Help!



[TOPIC: post.html]
#2

baykalsarioglu

[GLOBAL: userInfoPane.html]
baykalsarioglu
  • Observer

  • 16 posts
  • Corona SDK

OK, I remembered  that I already posted about this back then; https://forums.coronalabs.com/topic/71637-storeinit-hangs/

 

The problem is exactly the same! I have no idea why the problem is still there. 

without apple-iap, store.init hangs no transactionCallback, with apple-iap IAPs are invalid...



[TOPIC: post.html]
#3

baykalsarioglu

[GLOBAL: userInfoPane.html]
baykalsarioglu
  • Observer

  • 16 posts
  • Corona SDK

YAY!!! I've solved it! I just changed the name of the profile. Somehow it worked :)




[topic_controls]
[/topic_controls]