Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Xcode Corona Compatibility
Started by Edissey Dec 01 2019 09:53 AM

3 replies to this topic
ios xcode

Best Answer Edissey , 01 December 2019 - 07:54 PM

OK. Turns out I downloaded and installed the latest daily build BUT it did not replace the existing app so I was still running that one and not the latest.

Running the latest got rid of the error.

 

Thanks again.

[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

Edissey

[GLOBAL: userInfoPane.html]
Edissey
  • Enthusiast

  • 43 posts
  • Corona SDK

Apologies in advance if this has been fully answered elsewhere. The only relevant post I found was from early in the year and it does not provide the complete story.

 

I am running the latest Xcode (11.2.1) and Corona daily build (12/1/19) and am getting the "UNSUPPORTED iOS SDK Mismatch... You should consider updating your version of Xcode or using xcode-select to enable a compatible version" message.

 

The first part of the message does not make sense since I am running the latest version of Xcode. The second part is unclear. The iOS SDK dropdown prompts to select version 9.3 or 9.4 of Xcode. That's 2 versions behind the current version. Is that correct? See attached pic.

 

Also, is there a Coronalabs published (not Wikipedia) chart anywhere that shows which versions of Corona are compatible with which versions of Xcode / iOS?

 

Thank you.

 

Dan G.

 

 

Attached Files



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,393 posts
  • Enterprise

You need to download the latest daily build.

 

The link is at the top of this page.

 

Rob



[TOPIC: post.html]
#3

Edissey

[GLOBAL: userInfoPane.html]
Edissey
  • Enthusiast

  • 43 posts
  • Corona SDK

I did download the latest daily build (please see above).

 

Thank you.



[TOPIC: post.html]
#4

Edissey

[GLOBAL: userInfoPane.html]
Edissey
  • Enthusiast

  • 43 posts
  • Corona SDK

  Best Answer

OK. Turns out I downloaded and installed the latest daily build BUT it did not replace the existing app so I was still running that one and not the latest.

Running the latest got rid of the error.

 

Thanks again.




[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: ios, xcode