Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

plugin.openssl not loaded in Corona Simulator (windows)
Started by davidafisher Nov 20 2019 06:54 AM

- - - - -
1 reply to this topic
socket security
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

davidafisher

[GLOBAL: userInfoPane.html]
davidafisher
  • Observer

  • 6 posts
  • Corona SDK

I have the following in my build settings

 

-----------------------------------

settings = 
{
    plugins = 
    {      
        ["plugin.openssl"] =
        {
            publisherId = "com.coronalabs",
        },
 
        ["plugin.luaproc"] =
        {
            publisherId = "com.coronalabs",
        },
    },
 
-- Supported values for orientation:
-- portrait, portraitUpsideDown, landscapeLeft, landscapeRight
 
    orientation = 
        {
            default = "portrait",
            supported = { "portrait", },
        },
    }
------------------------------------------------------------------
 
on attempting to run the project the following error occurs
 
-----------------------------------------------------
 
09:35:50.198  WARNING: plugin.openssl is not configured in build.settings
09:35:50.198  
09:35:50.198  ERROR: Runtime error
09:35:50.198  module 'plugin_openssl' not found:
09:35:50.198  no field package.preload['plugin_openssl']
09:35:50.198  no file 'C:\Users\David Fisher\AppData\Roaming\Corona Labs\Corona Simulator\Plugins\plugin_openssl.lua'
09:35:50.198  no file 'C:\Users\David Fisher\Documents\Corona Projects\hatchingthematch\plugin_openssl.lua'
09:35:50.198  no file 'C:\Program Files (x86)\Corona Labs\Corona\Resources\plugin_openssl.lua'
09:35:50.198  no file '.\plugin_openssl.lua'
09:35:50.198  no file 'C:\Program Files (x86)\Corona Labs\Corona\lua\plugin_openssl.lua'
09:35:50.198  no file 'C:\Program Files (x86)\Corona Labs\Corona\lua\plugin_openssl\init.lua'
09:35:50.198  no file 'C:\Program Files (x86)\Corona Labs\Corona\plugin_openssl.lua'
09:35:50.198  no file 'C:\Program Files (x86)\Corona Labs\Corona\plugin_openssl\init.lua'
09:35:50.198  no file 'C:\Users\David Fisher\AppData\Roaming\Corona Labs\Corona Simulator\Plugins\plugin_openssl.dll'
09:35:50.198  no file '.\plugin_openssl.dll'
09:35:50.198  no file 'C:\Program Files (x86)\Corona Labs\Corona\Resources\plugin_openssl.dll'
09:35:50.198  no file '.\plugin_openssl.dll'
09:35:50.198  no file 'C:\Program Files (x86)\Corona Labs\Corona\plugin_openssl.dll'
09:35:50.198  no file 'C:\Program Files (x86)\Corona Labs\Corona\loadall.dll'
09:35:50.198  no file 'C:\Users\David Fisher\AppData\Roaming\Corona Labs\Corona Simulator\Plugins\plugin_openssl.dll'
09:35:50.198  no file '.\plugin_openssl.dll'
09:35:50.198  no file 'C:\Program Files (x86)\Corona Labs\Corona\Resources\plugin_openssl.dll'
09:35:50.198  no file '.\plugin_openssl.dll'
09:35:50.198  no file 'C:\Program Files (x86)\Corona Labs\Corona\plugin_openssl.dll'
09:35:50.198  no file 'C:\Program Files (x86)\Corona Labs\Corona\loadall.dll'
09:35:50.198  stack traceback:
09:35:50.198  [C]: in function 'require'
09:35:50.198  ?: in function 'require'
 
-------------------------------------------------
 
WHAT DO I NEED TO DO TO CORRECT THIS??

 



[TOPIC: post.html]
#2

kimberlyrandall572

[GLOBAL: userInfoPane.html]
kimberlyrandall572
  • Observer

  • 1 posts
  • Corona SDK

I have found to much error as a syntax error. mywegmansconnect




[topic_controls]
[/topic_controls]