Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Invalid Toolchain
Started by tap32 Nov 06 2019 10:40 AM

15 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

tap32

[GLOBAL: userInfoPane.html]
tap32
  • Contributor

  • 252 posts
  • Corona SDK

I'm trying to upload an app and am getting the following error:

ERROR ITMS-90534: "Invalid Toolchain. Your app was built with an unsupported version of Xcode or SDK. If you plan to submit this build to the App Store, make sure you are using the GM version of Xcode 10.1 and the SDK for iOS 12.1 and watchOS 5.1, Xcode 7.1 and the SDK for tvOS 9, or Xcode 6 and the SDK for macOS 10.9 or later. If you are using an Xcode beta version to test your app, make sure you are using the latest supported version. For more information about supported beta versions, view the App Store Connect What's New page (https://developer.apple.com/app-store-connect/whats-new/)."

WARNING ITMS-90703: "Deprecated Xcode Build. Due to resolved app archives issues, we have deprecated Xcode 11.2 on November 5, 2019. Download Xcode 11.2.1 or newer, rebuild your app and resubmit."

Anyone know what might be causing this? I have Xcode 11.2 11B52 installed, and don't see any updates in the app store.

 

Wait, so have Apple deprecated the latest Xcode only a few days after it was released?


Edited by tap32, 06 November 2019 - 10:41 AM.


[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,300 posts
  • Enterprise

The Warning isn't anything to worry about. A new Xcode will be out and we will cut a new daily build that supports it.

 

The Error is a bit more bothersome. I'll get Engineering to investigate.

 

Rob



[TOPIC: post.html]
#3

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,300 posts
  • Enterprise

What version of Corona are you using?

 

Rob



[TOPIC: post.html]
#4

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 921 posts
  • Corona Staff

It seems something went wrong on Apple side. Lets wait couple days for 11.2.1, we are using latest app store version of Xcode to build Corona ¯\_(ツ)_/¯

Hopefully it will go away soon.



[TOPIC: post.html]
#5

javier780

[GLOBAL: userInfoPane.html]
javier780
  • Observer

  • 9 posts
  • Corona SDK

Hi. I'm having the same issue. I downloaded Xcode 11.2.1 but the App will be signed with 11.2.0 still. But I understand that is just a warning, but the error seems to not go away. Should I try to install a previous Xcode version (10.1 GM) ?



[TOPIC: post.html]
#6

javier780

[GLOBAL: userInfoPane.html]
javier780
  • Observer

  • 9 posts
  • Corona SDK

I'm using the 3547 Daily Build, by the way.



[TOPIC: post.html]
#7

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,300 posts
  • Enterprise

We have to update our build servers to 11.2.1 as well and issue a new daily build. It was not available when we looked last, but that was yesterday. That will deal with the warning, the error, as @vlads mentioned above is something on Apple's end that they have to sort out.

 

Ro 



[TOPIC: post.html]
#8

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 921 posts
  • Corona Staff

11.2.1 is not released yet. It is in GM Seed, but usually it's best to wait for actual release. For now I would suggest using previous version of Corona (3545) which is built against the 11.1.



[TOPIC: post.html]
#9

oromanetti

[GLOBAL: userInfoPane.html]
oromanetti
  • Contributor

  • 236 posts
  • Corona SDK

Same problem here



[TOPIC: post.html]
#10

oromanetti

[GLOBAL: userInfoPane.html]
oromanetti
  • Contributor

  • 236 posts
  • Corona SDK

I've just used 3545 as Vlads suggested and I've got this warning :

 

 

UNSUPPORTED IOS SDK Mismatch

The version of iOS SDK (13.2) that's installed on this computer does not match the target iOS version (12.4). You may encounter issues building or incompatibilities at runtime.

You should consider updating your version of Xcode or using xcode-select to enable a compatible version.

Do you want to proceed with a build?



[TOPIC: post.html]
#11

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,300 posts
  • Enterprise

You need to drop back to Xcode 11.1 as well. They have to be matched or you will get this warning.  Likely it won't be a problem, but if you want to be safe, you have to get an older Xcode.

 

Rob



[TOPIC: post.html]
#12

runewinse

[GLOBAL: userInfoPane.html]
runewinse
  • Contributor

  • 502 posts
  • Corona SDK

11.2.1 is not released yet. It is in GM Seed, but usually it's best to wait for actual release. For now I would suggest using previous version of Corona (3545) which is built against the 11.1.

 

I don´t get it. Why are you releasing Corona versions (3547+) that require something that is not released (Xcode 11.2.1) ?

 

I stil do not see any signs of 11.2.1. Is it available for anybody else?



[TOPIC: post.html]
#13

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 921 posts
  • Corona Staff

We do not require Xcode 11.2.1. Apple released Xcode 11.2. Found a bug in it. Blocks all apps built with Xcode 11.2. Which is current version in App Store. This is not only Corona issue.
Apple is testing new release 11.2.1. We are not using it. As soon as Apple release 11.2.1 to App Store we would make a new build using it.

[TOPIC: post.html]
#14

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 921 posts
  • Corona Staff

If you urgently need to push the version now, I would suggest downgrading Xcode to 11.1 (you can download it https://developer.apple.com/downloads ) and using Corona 3545.
But my suggestion is wait a little big, until Corona and Xcode get an update.

[TOPIC: post.html]
#15

runewinse

[GLOBAL: userInfoPane.html]
runewinse
  • Contributor

  • 502 posts
  • Corona SDK

But my suggestion is wait a little big, until Corona and Xcode get an update.

 

I was under the impression that Xcode would get an update very soon, but the days go by. Any idea if this is a "few days" or a "few weeks" situation? If it´s the latter I´ll have to go through the downgrade path to get my stuff out.



[TOPIC: post.html]
#16

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,300 posts
  • Enterprise

That is likely going to be the fastest solution for now,

 

Rob




[topic_controls]
[/topic_controls]