Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

"Could not find the Java Development Kit (JDK)" error despite having it installed
Started by zodiac44 Oct 04 2019 02:16 AM

1 reply to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

zodiac44

[GLOBAL: userInfoPane.html]
zodiac44
  • Observer

  • 1 posts
  • Corona SDK

I'm using the latest daily build of Corona SDK (2019.3531), and OpenJDK 13. I'm on Windows 10.

 

All I have in my project is a Blank template with phone presets, and a "display.newText" call in main.lua. I haven't changed anything else.

 

I've made sure that both my Path variable and JAVA_HOME are pointing at the JDK at this location: C:\Program Files (x86)\Java\jdk-13\bin\

 

I've tried searching for this problem online, and one of them suggested using the 32 bit version of the JDK, but that hasn't worked either. I'm not really sure if I need the 32 bit version though, since Corona was recently updated to support the 64 bit Google Play requirements.

 

Any ideas?



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,207 posts
  • Enterprise

I would suggest looking through the posts in the Android 64-bit beta forum and look for suggestions on Java. I think most people have the best success with the JDK from Oracle version 8.1.

 

Rob




[topic_controls]
[/topic_controls]