Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Building for Xcode 11.0 works, 11.1 doesn't
Started by borderleap Sep 28 2019 12:40 PM

3 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

borderleap

[GLOBAL: userInfoPane.html]
borderleap
  • Contributor

  • 403 posts
  • Corona SDK

Figured you guys might be working on this or just hadn't released an updated daily build yet... I installed Xcode 11.1 GM seed but xad to revert back to Xcode 11.0 so that it'd build for iOS 13.0... 11.1 breaks in the build process.



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,207 posts
  • Enterprise

Can you be more descriptive in what you mean by "breaks the build process"?

 

Rob



[TOPIC: post.html]
#3

borderleap

[GLOBAL: userInfoPane.html]
borderleap
  • Contributor

  • 403 posts
  • Corona SDK

Hey Rob, sorry about that!  I already uninstalled it to reinstall 11.0, but remember in the build for iOS dialog for iOS SDK there was a "12.4" entry, then a "13.0 entry" and another one for "12.4" again which it'd auto-selected to, but threw up an "Xcode Mismatch" error.



[TOPIC: post.html]
#4

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,207 posts
  • Enterprise

The current daily build either uses iOS 13 or 12.4 depending on which version of Xcode you have installed. But even then if it's off by a version you should still be able to build even with the mis-match.

 

I don't know that we've added 13.1/xcode 11.1 yet.

 

Rob




[topic_controls]
[/topic_controls]