Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

How to use newer versions of LUA?
Started by Le Mustage Sep 18 2019 07:06 AM

1 reply to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

Le Mustage

[GLOBAL: userInfoPane.html]
Le Mustage
  • Observer

  • 1 posts
  • Corona SDK

Hey, it's my first topic in CoronaSDK forums!

 

I just noticed that we're using LUA 5.1 when already LUA 5.4 came out.

print(_VERSION)

Check official LUA Version history.

 

How can we update it to 5.4?

 

Thank you.



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,207 posts
  • Enterprise

Hi @Le Mustage and welcome to the Corona community forums.

 

The short answer is you can't.  We don't use an external Lua compiler. Lua 5.1 is embedded into the Corona Core and if we upgraded the volume of potential breaking changes that we dropped on developers would be quite a painful update.

 

Rob




[topic_controls]
[/topic_controls]