Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

What is the latest supported macOS and Xcode version?
Started by fly4 Sep 06 2019 03:08 PM

5 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

fly4

[GLOBAL: userInfoPane.html]
fly4
  • Observer

  • 29 posts
  • Corona SDK

I tried loading a fresh Mojave/10.14 system with Xcode 10.3 and Corona complained saying it wasn't ready for Mojave.

I then loaded a fresh High Sierra/10.13 system, but Xcode 10.3 won't install in it.

 

What combo do I need to use? I think I recall being able to get older Xcode versions from the developer portal.

 

Can I use Mojave/Xcode10.3 and ignore the "macOS Version Warning" or do I need to use High Sierra/Xcode10.1(latest for HS I think)?

 

I looked in this forum and Googled around and couldn't find suggestions.



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,062 posts
  • Enterprise

Corona runs just fine on Mojave. Periodically macOS will pop up a warning box, but you can safely click it away. I'm running Mojave 10.14.6.

 

As for Xcode, the current version is 10.3 (10G8).

 

Rob


  • fly4 likes this

[TOPIC: post.html]
#3

fly4

[GLOBAL: userInfoPane.html]
fly4
  • Observer

  • 29 posts
  • Corona SDK

Thanks Rob.

So I guess I can go with Mojave 10.14.6, Xcode 10.3, and Corona public release 2018.3326 and just ignore the OS warning.



[TOPIC: post.html]
#4

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,062 posts
  • Enterprise

I would not use 2018.3326. It's paired up with something like Xcode 9.2. You should use a recent daily build. I want to say we added support for iOS 12.4/Xcode 10.3 in like 2019.3507 or so. You can look at the release notes and see where we updated the iOS SDK and use something more modern. Most changes lately have to do with Google Android 64-bit releases, so the iOS side is pretty stable.

 

Rob



[TOPIC: post.html]
#5

fly4

[GLOBAL: userInfoPane.html]
fly4
  • Observer

  • 29 posts
  • Corona SDK

So should I just use the most recent daily build?



[TOPIC: post.html]
#6

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,062 posts
  • Enterprise

Yes




[topic_controls]
[/topic_controls]