Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

build error#1 corona sdk 2019 3509
Started by edkayce Aug 08 2019 11:34 AM

31 replies to this topic
build
[TOPIC CONTROLS]
Page 1 of 2 1 2
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

edkayce

[GLOBAL: userInfoPane.html]
edkayce
  • Observer

  • 21 posts
  • Corona SDK

since i moved to the new corona version , my corona dont build aany app;

 

the logs:

https://pastebin.com/Z5jaXh9z

 

 



[TOPIC: post.html]
#2

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 972 posts
  • Corona Staff

Do you have Android Studio installed by any chance? It seems like path for your user is getting messed up somehow. Like, your user seems to be simple ASCII string, but it doesn't behave like that.


  • saidelharech likes this

[TOPIC: post.html]
#3

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 972 posts
  • Corona Staff

Please, try again using latest daily build



[TOPIC: post.html]
#4

edkayce

[GLOBAL: userInfoPane.html]
edkayce
  • Observer

  • 21 posts
  • Corona SDK

i tried it



[TOPIC: post.html]
#5

edkayce

[GLOBAL: userInfoPane.html]
edkayce
  • Observer

  • 21 posts
  • Corona SDK

but is the same.....error



[TOPIC: post.html]
#6

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 972 posts
  • Corona Staff

OK. Do you have android Studio installed?

Only time when I seen errors like this is when user had non-ascii symbols in their name or something similar. Also, for some reason, your username is getting shortened, even if it doesn't have any non-ascii in it.



[TOPIC: post.html]
#7

edkayce

[GLOBAL: userInfoPane.html]
edkayce
  • Observer

  • 21 posts
  • Corona SDK

I insltaled android studio last year.... But for now I haven't it

[TOPIC: post.html]
#8

edkayce

[GLOBAL: userInfoPane.html]
edkayce
  • Observer

  • 21 posts
  • Corona SDK

Hi Vlad! I installed the last build , jdk version and the android tudio as you asked me! But i its give the same error!

Help me please! I'm lost -_-

 

what i must do?



[TOPIC: post.html]
#9

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 972 posts
  • Corona Staff

OK. Lets do the following. In start menu find Corona Native. It's a directory. From it copy Project Template/App somewhere (where you have your projects).

After which, open Android studio, and select "Open existing android studio project" and select <location you copied App to>/android.

 

Then try building it.



[TOPIC: post.html]
#10

edkayce

[GLOBAL: userInfoPane.html]
edkayce
  • Observer

  • 21 posts
  • Corona SDK

Failed again!

What about the gradle problem that come in the log output?I don't understand it, but it's cause the build fail!

[TOPIC: post.html]
#11

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 972 posts
  • Corona Staff

Wait. Android studio build failed? Ok. Try selecting “grade” on the right panel, in the drop down select app - build and then double click “assemble”
Please share android studio build log which will appear in the bottom

[TOPIC: post.html]
#12

edkayce

[GLOBAL: userInfoPane.html]
edkayce
  • Observer

  • 21 posts
  • Corona SDK

Sorry I didn't understand good!

I tried with corona!
But now I'm doing it with android studio!
It's processing....I'll tell something after that

[TOPIC: post.html]
#13

edkayce

[GLOBAL: userInfoPane.html]
edkayce
  • Observer

  • 21 posts
  • Corona SDK

the build fail in android studio too....the build output

 

 

https://pastebin.com/bGbDh8Cz



[TOPIC: post.html]
#14

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 972 posts
  • Corona Staff

Wow. Can you try creating new Android Studio (no Corona, just Android) project and compile it?

[TOPIC: post.html]
#15

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 972 posts
  • Corona Staff

OK. Here is the thing: everything points out to that you have some NON-ASCII symbols in your user name. But from what I see from the build log, there aren't any. It's just latin "Kprogrammer". This is extremely weird, and I can't put my finger on why it is happening.

Is there any chance you got some non-latin letters in your user home directory? Like ö or ø or something like that? Or may be cyrillic letter or anything of this sort?



[TOPIC: post.html]
#16

edkayce

[GLOBAL: userInfoPane.html]
edkayce
  • Observer

  • 21 posts
  • Corona SDK

i tried to build a simple android studio apk, but i give the same error that come in corona log output..

 

https://pastebin.com/idbcGUzQ



[TOPIC: post.html]
#17

edkayce

[GLOBAL: userInfoPane.html]
edkayce
  • Observer

  • 21 posts
  • Corona SDK

I downgraded my android build grade to 3.2.1 and now it's building android studio projects!

And now, what is the next step?

[TOPIC: post.html]
#18

edkayce

[GLOBAL: userInfoPane.html]
edkayce
  • Observer

  • 21 posts
  • Corona SDK

Hi Vlads! I have been trying.....but nothing

I waiting for you! I so down with this problem :mellow:



[TOPIC: post.html]
#19

edkayce

[GLOBAL: userInfoPane.html]
edkayce
  • Observer

  • 21 posts
  • Corona SDK

its possible to change the corona manually to 'com.android.tools.build:gradle:3.2.1



[TOPIC: post.html]
#20

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 972 posts
  • Corona Staff

Please try latest daily build.

[TOPIC: post.html]
#21

edkayce

[GLOBAL: userInfoPane.html]
edkayce
  • Observer

  • 21 posts
  • Corona SDK

:( :(.....again again and again failed.........some one to help me please?please!please!please!please!please!please!



[TOPIC: post.html]
#22

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 972 posts
  • Corona Staff

1. try latest daily build

2. try moving your project and output directory to C: (or whatever system drive you're using)



[TOPIC: post.html]
#23

edkayce

[GLOBAL: userInfoPane.html]
edkayce
  • Observer

  • 21 posts
  • Corona SDK

im using the last build and my project is in the drive C



[TOPIC: post.html]
#24

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 972 posts
  • Corona Staff

Unistall java, reboot comuputer then install java 1.8 from here https://www.oracle.com/technetwork/java/javase/downloads/index.html

(it's called JDK, "Java SE 8u221")



[TOPIC: post.html]
#25

edkayce

[GLOBAL: userInfoPane.html]
edkayce
  • Observer

  • 21 posts
  • Corona SDK

vlads , you reminde that you tell me to try with android studio?

i tryed, and in android studio dont build and show the same error if the android.build.tools is 3.4.1, but when i downgrade the build tool the apk  build




[topic_controls]
Page 1 of 2 1 2
 
[/topic_controls]

Also tagged with one or more of these keywords: build