Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Issue with Tiled and Berry
Started by koutzen Aug 07 2019 04:26 PM

No replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

koutzen

[GLOBAL: userInfoPane.html]
koutzen
  • Observer

  • 2 posts
  • Corona SDK

I'm doing my first attempt at creating a tileset based map using Tiled. I've tried using PonyTiled with which I was able to load my map but it didn't have the collision boxes I made using this guide:  http://doc.mapeditor.org/en/stable/manual/editing-tilesets/?highlight=collision#tile-collision-editor
 
Then I tried Berry which gives me the following error: 
"pl\ldurniat\Tile.lua:215: attempt to index field 'sprite' (a nil value)"
 
So I did some searching and found this thread where Idurniat created a simple testmap: https://forums.coronalabs.com/topic/72295-creating-platformer-level-with-physics-using-tiled/ 
 
I downloaded the project, checked that it worked and switched out the map in the project with my own map and got the same error. 
 
The only change I made was the filename of the map from Map.json to testmap.json (my map) so clearly the error is in my map and not the code.
 
I'm not really sure what I'm doing wrong and was hoping someone would know what my error means? 
 
My test map is just 2 png files that's each a 32x32 tile, one red the other green, the red has collision boxes added. Both are tile layers and included in the same folder as the json file. It looks like this: https://ibb.co/PW3Z9Ms (loaded in PonyTiled - as you can see it lacks physics so I tried Berry instead and got the error I'm describing)
 
Here is Map.json (original map - working): https://pastebin.com/9K709Yb0
Here is testmap.json (my map - not working): https://pastebin.com/C2rWBLnv



[topic_controls]
[/topic_controls]