Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Problem with openssl plugin and 64 bits
Started by alfonso14 Aug 06 2019 04:06 AM

5 replies to this topic

Best Answer alfonso14 , 07 August 2019 - 12:56 AM

I have solved it.

The problem was that AppID had left it between the characters [and]. Besides the order is important. I have also removed the OneSignal plugin.

The build file stays like this:

 

settings = {
   orientation = {
      default = "portrait",
      supported = { "portrait", "portraitUpsideDown", },
   },
   android = {
  versionCode = "42", 
      largeHeap = true, 
      usesPermissions = {
         "android.permission.INTERNET",
         "com.android.vending.CHECK_LICENSE",
"android.permission.ACCESS_NETWORK_STATE",
      },
 
      usesFeatures = {
            { name = "android.hardware.camera", required = false },
            { name = "android.hardware.location", required = false },
            { name = "android.hardware.location.gps", required = false },
{ name = "android.hardware.bluetooth", required = false },
{ name = "android.hardware.location.network", required = false },
{ name = "android.hardware.microphone", required = false },
{ name = "android.hardware.telephony", required = false },
      },
  applicationChildElements =
        {
            [[
                <meta-data android:name="com.google.android.gms.ads.APPLICATION_ID"
                    android:value="ca-app-pub-xxxxxxxxxxx~xxxxx"/>
            ]],
        },   
},   
   plugins =
   {
  ["plugin.admob"] ={publisherId = "com.coronalabs"},
      ["plugin.openssl"] = { publisherId = "com.coronalabs"},
  ["CoronaProvider.native.popup.social"] = {publisherId = "com.coronalabs"}
   },
   
   excludeFiles =
{
-- Exclude unnecessary files for each platform
all = { "Icon.png", "Icon-*dpi.png",},
},
}

[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

alfonso14

[GLOBAL: userInfoPane.html]
alfonso14
  • Observer

  • 6 posts
  • Corona SDK

After compiling the app in 64 bits with Corona 2019.3510 and generating the file when testing it on my mobile gives me the following error.

 

I have not understood very well if the problem with the openssl plugin has been resolved or not. Is it a problem with the plugin and 64 bits or is it a problem with my app?

 

Thanks

Attached Files



[TOPIC: post.html]
#2

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Corona Geek

  • 1,009 posts
  • Corona Staff

Yes, it was resolved. Make sure to include it in your build.settings: https://docs.coronalabs.com/plugin/openssl/index.html#project-settings



[TOPIC: post.html]
#3

alfonso14

[GLOBAL: userInfoPane.html]
alfonso14
  • Observer

  • 6 posts
  • Corona SDK

Thanks Vlads, I added that line already. The problem seems to be that it was the order in which it was in the code



[TOPIC: post.html]
#4

alfonso14

[GLOBAL: userInfoPane.html]
alfonso14
  • Observer

  • 6 posts
  • Corona SDK

The file is:

 

settings = {
   orientation = {
      default = "portrait",
      supported = { "portrait", "portraitUpsideDown", },
   },
   plugins =
   {
  ["plugin.admob"] ={publisherId = "com.coronalabs"},
  ["plugin.OneSignal"] ={ publisherId = "com.onesignal",},
      ["plugin.openssl"] = { publisherId = "com.coronalabs"},
  ["CoronaProvider.native.popup.social"] = {publisherId = "com.coronalabs"}
   },
   applicationChildElements = {
            [[
                <meta-data android:name="com.google.android.gms.ads.APPLICATION_ID"
                    android:value="ca-app-pub-xxxxxxxxxxxxxxxxxxxxxxxxxxx"/>
            ]],
   },     
   android = {
      versionCode = "42", 
      largeHeap = true, 
      usesPermissions = {
         "android.permission.INTERNET",
         "com.android.vending.CHECK_LICENSE",
"android.permission.ACCESS_NETWORK_STATE",
      },
 
      usesFeatures = {
            { name = "android.hardware.camera", required = false },
            { name = "android.hardware.location", required = false },
            { name = "android.hardware.location.gps", required = false },
{ name = "android.hardware.bluetooth", required = false },
{ name = "android.hardware.location.network", required = false },
{ name = "android.hardware.microphone", required = false },
{ name = "android.hardware.telephony", required = false },
      }
   },
}
 
the error he gives me now is in the build
 
 Picked up JAVA_TOOL_OPTIONS: -Duser.language=en
09:46:15.312  Android build failed (1) after 56 seconds
09:50:54.456  Testing credentials for 'C:\Program Files (x86)\Corona Labs\Corona\Resources\Implementacion.keystore': 
09:50:55.529  jar signed.
09:50:55.529  Picked up JAVA_TOOL_OPTIONS: -Duser.language=en
09:50:56.324  Using custom build id from app bundle: 00000 (AppSettings.lua)
09:50:56.324  
09:50:56.324  Using custom Build Id 00000
09:51:48.295  @ver > NUL
09:51:48.295  Exception in thread "DisconnectableInputStream source reader" org.gradle.api.UncheckedIOException: java.io.IOException: Acceso denegado
09:51:48.295  at org.gradle.internal.UncheckedException.throwAsUncheckedException(UncheckedException.java:61)
09:51:48.295  at org.gradle.internal.UncheckedException.throwAsUncheckedException(UncheckedException.java:41)
09:51:48.295  at org.gradle.util.DisconnectableInputStream$1.run(DisconnectableInputStream.java:125)
09:51:48.295  at java.lang.Thread.run(Thread.java:748)
09:51:48.295  Caused by: java.io.IOException: Acceso denegado
09:51:48.295  at java.io.FileInputStream.readBytes(Native Method)
09:51:48.295  at java.io.FileInputStream.read(FileInputStream.java:255)
09:51:48.295  at java.io.BufferedInputStream.fill(BufferedInputStream.java:246)
09:51:48.295  at java.io.BufferedInputStream.read1(BufferedInputStream.java:286)
09:51:48.295  at java.io.BufferedInputStream.read(BufferedInputStream.java:345)
09:51:48.295  at org.gradle.util.DisconnectableInputStream$1.run(DisconnectableInputStream.java:96)
09:51:48.295  ... 1 more
09:51:48.295  C:\Users\alfonso\AppData\Local\Temp\Corona Labs\CLtmpa08924\template\app\src\main\AndroidManifest.xml:101:11-91 Error:
09:51:48.295  Element service#com.onesignal.SyncService at AndroidManifest.xml:101:11-91 duplicated with element declared at AndroidManifest.xml:88:11-92
09:51:48.295  C:\Users\alfonso\AppData\Local\Temp\Corona Labs\CLtmpa08924\template\app\src\main\AndroidManifest.xml Error:
09:51:48.295  Validation failed, exiting
09:51:48.295  
09:51:48.295  FAILURE: Build failed with an exception.
09:51:48.295  
09:51:48.295  * What went wrong:
09:51:48.295  Execution failed for task ':App:processReleaseManifest'.
09:51:48.295  > Manifest merger failed with multiple errors, see logs
09:51:48.295  
09:51:48.295  * Try:
09:51:48.295  Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
09:51:48.295  
09:51:48.295  * Get more help at https://help.gradle.org
09:51:48.295  
09:51:48.295  BUILD FAILED in 49s
09:51:48.295  Picked up JAVA_TOOL_OPTIONS: -Duser.language=en
09:51:50.032  Android build failed (1) after 54 seconds
 


[TOPIC: post.html]
#5

alfonso14

[GLOBAL: userInfoPane.html]
alfonso14
  • Observer

  • 6 posts
  • Corona SDK

  Best Answer

I have solved it.

The problem was that AppID had left it between the characters [and]. Besides the order is important. I have also removed the OneSignal plugin.

The build file stays like this:

 

settings = {
   orientation = {
      default = "portrait",
      supported = { "portrait", "portraitUpsideDown", },
   },
   android = {
  versionCode = "42", 
      largeHeap = true, 
      usesPermissions = {
         "android.permission.INTERNET",
         "com.android.vending.CHECK_LICENSE",
"android.permission.ACCESS_NETWORK_STATE",
      },
 
      usesFeatures = {
            { name = "android.hardware.camera", required = false },
            { name = "android.hardware.location", required = false },
            { name = "android.hardware.location.gps", required = false },
{ name = "android.hardware.bluetooth", required = false },
{ name = "android.hardware.location.network", required = false },
{ name = "android.hardware.microphone", required = false },
{ name = "android.hardware.telephony", required = false },
      },
  applicationChildElements =
        {
            [[
                <meta-data android:name="com.google.android.gms.ads.APPLICATION_ID"
                    android:value="ca-app-pub-xxxxxxxxxxx~xxxxx"/>
            ]],
        },   
},   
   plugins =
   {
  ["plugin.admob"] ={publisherId = "com.coronalabs"},
      ["plugin.openssl"] = { publisherId = "com.coronalabs"},
  ["CoronaProvider.native.popup.social"] = {publisherId = "com.coronalabs"}
   },
   
   excludeFiles =
{
-- Exclude unnecessary files for each platform
all = { "Icon.png", "Icon-*dpi.png",},
},
}


[TOPIC: post.html]
#6

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Corona Geek

  • 1,009 posts
  • Corona Staff

Are you using OpenSSL?  Because OneSignal was the one using it.




[topic_controls]
[/topic_controls]