Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

iOS build issue for build #3508
Started by borderleap Jul 29 2019 07:48 AM

3 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

borderleap

[GLOBAL: userInfoPane.html]
borderleap
  • Contributor

  • 400 posts
  • Corona SDK

Just installed Xcode 10.3 and the latest daily build...  all was working just fine but now I receive this error when trying to build for iOS...

ERROR: build command failed: xcrun actool --output-format human-readable-text --warnings --export-dependency-info "/var/folders/pw/6g7hl9qd0jdc0214d60r_92r0000gn/T/CLtmpLzk4Pg/assetcatalog_dependencies" --output-partial-info-plist "/var/folders/pw/6g7hl9qd0jdc0214d60r_92r0000gn/T/CLtmpLzk4Pg/assetcatalog_generated_info.plist" --compress-pngs --enable-on-demand-resources YES --product-type com.apple.product-type.application --compile "/Users/nate/Documents/Builds/iOS/test.app" --target-device iphone --target-device ipad --minimum-deployment-target 8.0 --platform iphoneos --app-icon AppIcon "Images.xcassets"
Jul 28 10:20:13.624 ERROR: with exit code 1 and output: 
Jul 28 10:20:13.624 
Jul 28 10:20:13.626 ERROR: while compiling icons: 
Jul 28 10:20:13.626 BUILD ERROR: 
Jul 28 10:20:13.626 iOS build failed (12) after 32 seconds
Jul 28 10:20:13.886 ERROR: Build Failed: 


[TOPIC: post.html]
#2

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 800 posts
  • Corona Staff

Hello! Can you please run following command:

defaults write com.coronalabs.Corona_Simulator debugBuildProcess -int 5

It would be best if before building you would clean the console output (⌘K) and use pastebit.com to show what the output is. Plese, copy full contents of the console, not just error bit.

Your build.settings file (use pastebit.com for that as well) would be helpful too.
I don't have any issues building with 3508, so probably some plugins.


[TOPIC: post.html]
#3

borderleap

[GLOBAL: userInfoPane.html]
borderleap
  • Contributor

  • 400 posts
  • Corona SDK

Thanks Vlad.  I'll give this a try.

 

Here's another forum post I just found with the same problem:

https://forums.coronalabs.com/topic/75946-ios-build-fails-with-20193508



[TOPIC: post.html]
#4

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Corona Geek

  • 1,172 posts
  • Corona SDK

Just looks like you are missing icons. In xcode open a new game project add your icons to that project and then copy the icon folder and xml to the corona build.




[topic_controls]
[/topic_controls]