Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Disable Appodeal Toast Messages
Started by pau7 Jul 25 2019 07:35 AM

2 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

pau7

[GLOBAL: userInfoPane.html]
pau7
  • Enthusiast

  • 42 posts
  • Corona SDK

Hello,

 

I'm working with Appodeal plugin and I want to disable some networks. In the build.settings file I have commented some of the networks. When the app starts some messages appear in the screen. They are something like: "ERROR: AmazonAds not found". I get one for each disabled network. Is there a way to hide or disable this messages? I don't want my users to see error messages. Thank you for your help!

 



[TOPIC: post.html]
#2

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Corona Geek

  • 1,242 posts
  • Corona SDK

You just have to put them in the list of disabled networks. Like this:

appodeal.init( adProvider.adListener, { appKey="xxx", disableWriteExternalPermissionCheck=true, disableNetworks = {"mintegral", "my_target", "vungle"} } )

There was another post with this same question that I can't find at the moment. But this was the solution.



[TOPIC: post.html]
#3

pau7

[GLOBAL: userInfoPane.html]
pau7
  • Enthusiast

  • 42 posts
  • Corona SDK

Hello,

 

Thank you for your answer. It works!

 

Since you said that there was another post with the same question I made another search, but this time adding the word disableNetworks in the search field. This is what I found in the forums:

 

 
Sorry for the duplicate topic. First time I didn't find those posts.
 
Thank you!



[topic_controls]
[/topic_controls]