Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Crash on Startup 3502
Started by davidgmonical Jul 19 2019 10:54 AM

11 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

davidgmonical

[GLOBAL: userInfoPane.html]
davidgmonical
  • Enthusiast

  • 98 posts
  • Corona SDK

I'm seeing an issue that seems possibly related to licensing (which according to another post was fixed in 3502).

 

Here's the log:

https://pastebin.com/Ry2Rm3Ke

 

And build.settings

https://pastebin.com/UkJvc0s9

 

Thanks!

 

Edit: Tested without the licensing or google maps key and still see the same error.



[TOPIC: post.html]
#2

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 979 posts
  • Corona Staff

Hello!

Unfortunately I don't get same bug as you do using your build.setting. Please, help up figure it out:

1. Build some sample application and see if it works.

2. Build sample application with your build.settings

3. Build sample application with your build.settings and config.lua



[TOPIC: post.html]
#3

davidgmonical

[GLOBAL: userInfoPane.html]
davidgmonical
  • Enthusiast

  • 98 posts
  • Corona SDK

I tried building the sample app AnchorPoints (SampleCode/Graphics/AnchorPoint) without changing anything and using the debug key, and it fails.

 

Here's the log for it: https://pastebin.com/Hr7NDkb1



[TOPIC: post.html]
#4

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 979 posts
  • Corona Staff

Oh wow. It's a same crash :( Can you send me a full build log as described in pinned thread? Also, an APK which is getting built. And lastly, what device are you testing and building on?



[TOPIC: post.html]
#5

davidgmonical

[GLOBAL: userInfoPane.html]
davidgmonical
  • Enthusiast

  • 98 posts
  • Corona SDK

Here's the crash log following the steps in the post: https://pastebin.com/69hURtK9

 

It's actually saying I don't have permission to upload the APK so here it is on Google Drive

 

https://drive.google.com/file/d/12bfI2qOue4fPM8LsKZSD_cWksW6PTFJA/view?usp=sharing

 

I'm using an old phone, a Galaxy S3.



[TOPIC: post.html]
#6

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 979 posts
  • Corona Staff

Oh wow. This APK works perfectly on my phone. May be issue is with old android version. Good catch! Can you verify you android version



[TOPIC: post.html]
#7

davidgmonical

[GLOBAL: userInfoPane.html]
davidgmonical
  • Enthusiast

  • 98 posts
  • Corona SDK

It's 4.4.2 and API level 19



[TOPIC: post.html]
#8

sahil19.sindh

[GLOBAL: userInfoPane.html]
sahil19.sindh
  • Contributor

  • 156 posts
  • Corona SDK

I think the issue is because 64 bit build will work on 64 bit device/os. The s3 is not 64 bit supported. Need to test on some latest device that is 64 bit.



[TOPIC: post.html]
#9

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 979 posts
  • Corona Staff

It should work on both 32 and 64 bit devices. I’ll look into what is going on.

[TOPIC: post.html]
#10

sahil19.sindh

[GLOBAL: userInfoPane.html]
sahil19.sindh
  • Contributor

  • 156 posts
  • Corona SDK

Ok, Thanks for clearing this Vlads. 



[TOPIC: post.html]
#11

davidgmonical

[GLOBAL: userInfoPane.html]
davidgmonical
  • Enthusiast

  • 98 posts
  • Corona SDK

Is there any update on this?



[TOPIC: post.html]
#12

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 979 posts
  • Corona Staff

Sure. Try the latest version


[topic_controls]
[/topic_controls]