Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Build failed using Corona Build 2019.3502
Started by vrgandhi98 Jul 17 2019 10:54 PM

23 replies to this topic
64-bit build release corona

Best Answer vrgandhi98 , 30 July 2019 - 02:45 AM

Hello

 

I tried Latest daily build Build: 2019.3509

and now its working fine.
 
Thanks

[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

vrgandhi98

[GLOBAL: userInfoPane.html]
vrgandhi98
  • Observer

  • 10 posts
  • Corona SDK

I got error while building App using Corona Build 2019.3502

 

I got below error

 

https://pastebin.com/MnNmvVCG

 

JAVA - jdk-12.0.2 is intalled in my windows 7 - 

 

Please give soultion as soon as possible



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,925 posts
  • Enterprise

Can you up the debug level and try building again, from cmd.exe run:

 

reg ADD "HKEY_CURRENT_USER\Software\Ansca Corona\Corona Simulator\Preferences" /f /v debugBuildProcess /d 5

 

Thanks

Rob



[TOPIC: post.html]
#3

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 804 posts
  • Corona Staff

It seems like Corona failed to compile your Lua code. Please, do following:

1. Try building any sample

2. Try building any of the samples (You can open sample from the Welcome window)

3. Build the sample with your build.settings

I'll try to add more information on which file compilation is failing exactly in next build.



[TOPIC: post.html]
#4

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 804 posts
  • Corona Staff

It is also possible there is some problem with your config.lua.

Unfortunatelly it's really hard to tell what is going on with your project. Can you PM me please, so we can discuss how to diagnose this issue?



[TOPIC: post.html]
#5

vrgandhi98

[GLOBAL: userInfoPane.html]
vrgandhi98
  • Observer

  • 10 posts
  • Corona SDK

Hello Sir

 

I run sample code without using my build setting.

 

Still I got error
 



[TOPIC: post.html]
#6

vrgandhi98

[GLOBAL: userInfoPane.html]
vrgandhi98
  • Observer

  • 10 posts
  • Corona SDK

I run my project with Build 2019.3490 

 

And it works fine.

 

But can not generate .aab file.

 

It generate .apk file.

 

What is the issue with new build?

 

Thanks



[TOPIC: post.html]
#7

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 804 posts
  • Corona Staff

Can you share full build log, not just piece with the error?

[TOPIC: post.html]
#8

sahil19.sindh

[GLOBAL: userInfoPane.html]
sahil19.sindh
  • Contributor

  • 135 posts
  • Corona SDK

I have asked the same qn in some other thread but i think this is the right thread to ask my qn

I have downloaded and installed the Corona 3502 and try to create a new project, just empty project and took a build. The build failed with this message.

Here is my build fail log

https://pastebin.com/uCrg04jr

 

Here is the build.settings file

https://pastebin.com/GPvQgj2m

 

Please tell me if i am missing something, I am using Windows 10 and trying to build for Android.

I have a corona 32 bit installed in C: and this 64 bit i have installed in F: and trying to build using this one only.



[TOPIC: post.html]
#9

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 804 posts
  • Corona Staff

Oh, thanks. It seems like it fails because it can’t allocate enough RAM. How much ram does your computer has? It’s not really a problem, I’ll just have to adjust some constants

[TOPIC: post.html]
#10

sahil19.sindh

[GLOBAL: userInfoPane.html]
sahil19.sindh
  • Contributor

  • 135 posts
  • Corona SDK

ok, Its RAM is 4GB but i have another machine for graphics that is 8GB, so if you say i can try on that by installing Corona on that but as you said we can fix this by changing some constants so If that's an easy go then we can try that as well



[TOPIC: post.html]
#11

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 804 posts
  • Corona Staff

Oh. It seems like 2 different issues here. First, sahil19.sindh, your RAM issue is unrelated to original question. Please, next time create a new thread. To test the fix, replace android-template.zip with this file:
https://send.firefox.com/download/08f6013e80776305/#KM_QohMOXEHi3tCdOh8_6g

File can be found in "C:\Program Files (x86)\Corona Labs\Corona\Native\Corona\android\resources"

 

vrgandhi98 latest build can be found in pinned post:

https://forums.coronalabs.com/topic/75790-update-build-3502-handling-bugs-with-android-x64-and-target-sdk-28/



[TOPIC: post.html]
#12

vrgandhi98

[GLOBAL: userInfoPane.html]
vrgandhi98
  • Observer

  • 10 posts
  • Corona SDK

Hello vlads

Today I installed latest corona build  3504 and I faced same issue

See full log 

https://pastebin.com/tu7yfZQb

 

Thanks



[TOPIC: post.html]
#13

vrgandhi98

[GLOBAL: userInfoPane.html]
vrgandhi98
  • Observer

  • 10 posts
  • Corona SDK

Build Sample project with 3504 but same issue

see full console log of sample project

https://pastebin.com/mws9xLtD



[TOPIC: post.html]
#14

sahil19.sindh

[GLOBAL: userInfoPane.html]
sahil19.sindh
  • Contributor

  • 135 posts
  • Corona SDK

@vrgandho98, did you try replacing the zip file in corona that vlads gave in last reply.

[TOPIC: post.html]
#15

vrgandhi98

[GLOBAL: userInfoPane.html]
vrgandhi98
  • Observer

  • 10 posts
  • Corona SDK

Hello 

Link is not working right now.

If you have working link then please send 



[TOPIC: post.html]
#16

sahil19.sindh

[GLOBAL: userInfoPane.html]
sahil19.sindh
  • Contributor

  • 135 posts
  • Corona SDK

Tell me your email. I will send the zip file but you need to replace that exactly in the same location.

[TOPIC: post.html]
#17

vrgandhi98

[GLOBAL: userInfoPane.html]
vrgandhi98
  • Observer

  • 10 posts
  • Corona SDK

send me on vrgandhi98@gmail.com



[TOPIC: post.html]
#18

sahil19.sindh

[GLOBAL: userInfoPane.html]
sahil19.sindh
  • Contributor

  • 135 posts
  • Corona SDK

File sent, please replace in correct folder and try once again. If it works then please tell here so others can also get help.

[TOPIC: post.html]
#19

vrgandhi98

[GLOBAL: userInfoPane.html]
vrgandhi98
  • Observer

  • 10 posts
  • Corona SDK

Same issue brother.

I think its another issue.

Lets wait for vlads reply.



[TOPIC: post.html]
#20

sahil19.sindh

[GLOBAL: userInfoPane.html]
sahil19.sindh
  • Contributor

  • 135 posts
  • Corona SDK

ok, Np then we need to wait for Vlads



[TOPIC: post.html]
#21

vrgandhi98

[GLOBAL: userInfoPane.html]
vrgandhi98
  • Observer

  • 10 posts
  • Corona SDK

Hello vlads 

 

I am waiting for your reply.



[TOPIC: post.html]
#22

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,925 posts
  • Enterprise

While you wait on a reply from @vlads, please download the latest daily build and try that.

 

Rob



[TOPIC: post.html]
#23

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 804 posts
  • Corona Staff

vrgandhi98, I sent you new android-template.zip with way more diagnostics now when I know why it's failing. But it is taking too long to figure this out. Can you please get on Slack or something so we can figure this issue out? I'm trying to diagnose what is going on with it, but it really hard to do something when any attempt takes several days to test.



[TOPIC: post.html]
#24

vrgandhi98

[GLOBAL: userInfoPane.html]
vrgandhi98
  • Observer

  • 10 posts
  • Corona SDK

  Best Answer

Hello

 

I tried Latest daily build Build: 2019.3509

and now its working fine.
 
Thanks



[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: 64-bit build release, corona