Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

APP in crash on any device
Started by reattiva Jul 09 2019 12:21 AM

8 replies to this topic
crash

Best Answer vlads , 10 July 2019 - 06:06 AM

New build should fix this issue.

[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

reattiva

[GLOBAL: userInfoPane.html]
reattiva
  • Observer

  • 3 posts
  • Corona SDK

Hello, I built my app with “Corona 2019.3498.” and successful upload on “Google Play Console” the AAP (Android App Bundle) because the APK version was not accepted. After the donwload, and during the test, the app give me this error on different devices (ex. Huawei P30 and Samsung S9).

 

Screenshot attached.

 

Error messages: Runtime Error module 'licensing' not found:resource (licensing.lu) does not exist in archive no field package.preload['licensing'] no file '(null)/licensing.lua' no file'(null)/licensing.lua' no file '/data/app/ com.reattiva.everyweb-2M4dMWtybnmZCdmyXL4lKQ==/lib/arm64/liblicensing.so' no file'./licensing.so' no file '(null)/licensing.so' no file '/data/app/' com.reattiva.everyweb-2M4dMWtybnmZCdmyXL4lKQ==/lib/arm64/liblicensing.so' no file './licensing.so' no file '(null)/licensing.so'

 

Attached Files



[TOPIC: post.html]
#2

JoePringles

[GLOBAL: userInfoPane.html]
JoePringles
  • Contributor

  • 368 posts
  • Corona SDK

I mean I'm far from a good debugger but your project is trying to access: "licensing.lua" but it doesn't exist.

 

I think this a problem with your app itself instead of the android 64 feature.



[TOPIC: post.html]
#3

bamazy

[GLOBAL: userInfoPane.html]
bamazy
  • Contributor

  • 131 posts
  • Corona SDK

This problem is something that many of the developers are facing with the version you mentioned, and it seems to be related to plugins which are not compatible with Android 64-bit. You can try building with "Corona 2019.3490" and uploading to "Google Play Console". 



[TOPIC: post.html]
#4

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,408 posts
  • Enterprise

The problem is around Android 9 and the use of Android App Bundles with our 64-bit version of Android. This is why we are having people test this. Hopefully we will have news on this issue soon.

 

Rob


  • reattiva likes this

[TOPIC: post.html]
#5

reattiva

[GLOBAL: userInfoPane.html]
reattiva
  • Observer

  • 3 posts
  • Corona SDK

The problem is around Android 9 and the use of Android App Bundles with our 64-bit version of Android. This is why we are having people test this. Hopefully we will have news on this issue soon.

 

Rob

 

Thanks Rob,

I hope you resolve as soon as possible. Have you scheduled a release date?



[TOPIC: post.html]
#6

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 979 posts
  • Corona Staff

  Best Answer

New build should fix this issue.


  • reattiva likes this

[TOPIC: post.html]
#7

reattiva

[GLOBAL: userInfoPane.html]
reattiva
  • Observer

  • 3 posts
  • Corona SDK

I built my app with “Corona 2019.3502” and now it works.



[TOPIC: post.html]
#8

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,408 posts
  • Enterprise

Great news!



[TOPIC: post.html]
#9

bamazy

[GLOBAL: userInfoPane.html]
bamazy
  • Contributor

  • 131 posts
  • Corona SDK

Mine also works after the latest build. Thanks a lot!




[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: crash