Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Build failed for android using the latest corona build 2019.3495
Started by leokarun Jun 26 2019 06:03 AM

9 replies to this topic
android 64-bit build
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

leokarun

[GLOBAL: userInfoPane.html]
leokarun
  • Enthusiast

  • 45 posts
  • Corona SDK

Hey,

 

Glad that corona finally has a version that supports 64-bit builds. I installed the latest version i.e. 2019.3495 and created a new project from the simulator with only an empty main file. I then tried building that project for android but got an error message saying the build failed. The following text was being printed on the simulator's console.

 

19:16:54.041  WARNING: An illegal reflective access operation has occurred
19:16:54.041  WARNING: Illegal reflective access by org.codehaus.groovy.vmplugin.v7.Java7$1 (file:/C:/Users/famousdoggHP/.gradle/wrapper/dists/gradle-5.1.1-all/97z1ksx6lirer3kbvdnh7jtjg/gradle-5.1.1/lib/groovy-all-1.0-2.5.4.jar) to constructor java.lang.invoke.MethodHandles$Lookup(java.lang.Class,int)
19:16:54.041  WARNING: Please consider reporting this to the maintainers of org.codehaus.groovy.vmplugin.v7.Java7$1
19:16:54.041  WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
19:16:54.041  WARNING: All illegal access operations will be denied in a future release
19:16:54.041  
19:16:54.041  FAILURE: Build failed with an exception.
19:16:54.041  
19:16:54.041  * Where:
19:16:54.041  Build file 'C:\Users\famousdoggHP\AppData\Local\Temp\Corona Labs\CLtmpa04544\template\app\build.gradle.kts' line: 715
19:16:54.041  
19:16:54.041  * What went wrong:
19:16:54.041  C:\Users\famousdoggHP\AppData\Local\Temp\Corona Labs\CLtmpa04544\template\app\build\intermediates\corona-mega-jar does not exist.
19:16:54.041  
19:16:54.041  * Try:
19:16:54.041  Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
19:16:54.041  
19:16:54.041  * Get more help at https://help.gradle.org
19:16:54.041  
19:16:54.041  BUILD FAILED in 11s
19:16:54.228  Android build failed (1) after 13 seconds
 

  



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,212 posts
  • Enterprise

Let me run this by engineering

 

Rob



[TOPIC: post.html]
#3

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 890 posts
  • Corona Staff

Thanks, @leokarun, this will be fixed in next daily build, bug which wasn't in previous. If you build app with some plugins, it will go away. Or wait till next build is up.



[TOPIC: post.html]
#4

leokarun

[GLOBAL: userInfoPane.html]
leokarun
  • Enthusiast

  • 45 posts
  • Corona SDK

Okay, I tried to build an app after including some plugins and still got the exact same error. Guess I'll have to wait for the next build and hopefully this problem would be resolved by then. Cheers.



[TOPIC: post.html]
#5

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 890 posts
  • Corona Staff

Sorry about that. Single line of code to fix rare error broke a build :( New build is up. Only change is fix to that fix. Just replace numbers in URL to 2019.3496 (note, it's in two places)



[TOPIC: post.html]
#6

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,212 posts
  • Enterprise

Here are the new URLs:
 


[TOPIC: post.html]
#7

shashwat

[GLOBAL: userInfoPane.html]
shashwat
  • Enthusiast

  • 52 posts
  • Corona SDK

Thanks Rob and vlads- we're still experiencing some issues but we're trying out the latest builds on multiple systems now to try and figure out exactly where the problem is because the latest logs are not very clear on why it's failing. 

 

We'll post again as soon once we have some more details. We'll also test plugins extensively and report any issues that we find. Thanks :)



[TOPIC: post.html]
#8

leokarun

[GLOBAL: userInfoPane.html]
leokarun
  • Enthusiast

  • 45 posts
  • Corona SDK

Hey again @Rob & @vlads. After trying out the latest build( i.e. 2019.3496) the following were my observations -

 

- I was finally able to create a 64-bit build of a blank app created using corona simulator. I even tested the app on a device and it worked as expected which is great :)

 

- But when I tried building one of our working projects, I was getting some dependency related error on multiple systems. I have included a text file that contains the logs pertaining to the error. I suspect it could be due to one of the plugins. I'll anyway be looking to spend more time testing this, like try after removing some 3rd party plugins etc.

 

Please let me know if you could make out what the issue might be. Thanks for your support. 

Attached Files



[TOPIC: post.html]
#9

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 890 posts
  • Corona Staff

Keep in mind that this is basically closed alpha we are showing to pinpoint issues like that. Currently know issues in Corona itself are about Windows and non-ascii paths or names.
Also, as you seen for yourself, some plugins are still not working. If plugins don’t work for you, please, post which are broken

[TOPIC: post.html]
#10

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,212 posts
  • Enterprise

Hey all. This thread is becoming unmanagable. We've created a new forum just for Android 64 bit:

 

https://forums.coronalabs.com/forum/664-android-64-bit-testing/

 

Please read the pinned post at the top:

 

https://forums.coronalabs.com/topic/75790-handling-bugs-with-android-x64-and-target-sdk-28/

 

Please direct any testing related issues there.

 

Thanks

Rob




[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: android, 64-bit, build