Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Build Failed Error code: 256
Started by Aarbron Jun 10 2019 06:20 AM

7 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

Aarbron

[GLOBAL: userInfoPane.html]
Aarbron
  • Enthusiast

  • 87 posts
  • Corona SDK

I get this error.

Few hours I had no problem.

Didn't change anything.

I get the error whatever I try to build.

BUILD FAILED
/Applications/Corona-3474/Corona Simulator.app/Contents/Resources/build.xml:525: The following error occurred while executing this line:
/Applications/Corona-3474/Corona Simulator.app/Contents/Resources/build.xml:417: Failed to sign the APK.
                    
                    Total time: 6 seconds
Jun 10 05:15:37.222 
Jun 10 05:15:37.712 Android build failed (256) after 220 seconds
Jun 10 05:15:38.081 ERROR: Build Failed: Error code: 256


[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,684 posts
  • Enterprise

Do you have a complete console log from the build?

 

Rob



[TOPIC: post.html]
#3

Aarbron

[GLOBAL: userInfoPane.html]
Aarbron
  • Enthusiast

  • 87 posts
  • Corona SDK

Hi Rob.

Thank you for helping.

 

I thought it was a problem from Corona side.

Now I guess it's just me.

No worries I will find what I'm doing wrong :)



[TOPIC: post.html]
#4

bitcoin985

[GLOBAL: userInfoPane.html]
bitcoin985
  • Observer

  • 2 posts
  • Corona SDK

Hi Rob.

Thank you for helping.

 

I thought it was a problem from Corona side.

Now I guess it's just me.

No worries I will find what I'm doing wrong :)

 

Hi. Did you fix your error? I'm getting 256 too)) I think my error is in my keystore file, because when I build in debug mode (debug.keystore provided by corona), I don't get any error, but as soon as I use my created keystore to build apk, I'm getting error 256. Thank you.



[TOPIC: post.html]
#5

tap32

[GLOBAL: userInfoPane.html]
tap32
  • Contributor

  • 235 posts
  • Corona SDK

Hi Rob,

 

I am getting the same issue. This is my console output:

Jun 20 08:27:50.010 Using java version "1.8.0_65"
                    Java(TM) SE Runtime Environment (build 1.8.0_65-b17)
                    Java HotSpot(TM) 64-Bit Server VM (build 25.65-b01, mixed mode)
Jun 20 08:27:58.786 Using java version "1.8.0_65"
                    Java(TM) SE Runtime Environment (build 1.8.0_65-b17)
                    Java HotSpot(TM) 64-Bit Server VM (build 25.65-b01, mixed mode)
Jun 20 08:27:59.538 Building Android app for [...] 2019.3474
Jun 20 08:28:00.742 Using custom build id from app bundle: 00000 (AppSettings.lua)
Jun 20 08:28:02.135 BUILD SUCCESSFUL
                    Total time: 0 seconds
Jun 20 08:28:02.135
Jun 20 08:28:41.057 BuildID: 5d0bde43d7e11
Jun 20 08:28:46.804      [echo]  "creating unsigned.apk"
Jun 20 08:28:46.820
Jun 20 08:28:50.148      [exec] Result: 1
Jun 20 08:28:50.176
Jun 20 08:28:51.354      [exec] Result: 1
Jun 20 08:28:52.545      [exec] Result: 1
Jun 20 08:28:52.597 BUILD FAILED
                    /Applications/CoronaSDK/Corona Simulator.app/Contents/Resources/build.xml:525: The following error occurred while executing this line:
                    /Applications/CoronaSDK/Corona Simulator.app/Contents/Resources/build.xml:417: Failed to sign the APK.
                    
                    Total time: 9 seconds
Jun 20 08:28:52.598
Jun 20 08:28:52.749 Android build failed (256) after 51 seconds
Jun 20 08:28:53.102 ERROR: Build Failed: Error code: 256
Jun 20 08:28:53.102
 


[TOPIC: post.html]
#6

Aarbron

[GLOBAL: userInfoPane.html]
Aarbron
  • Enthusiast

  • 87 posts
  • Corona SDK

@bitcoin985 sorry for the delay.

 

In my case I caused the problem.

I renamed the keystore folder by mistake and Corona couldn't find it :)



[TOPIC: post.html]
#7

tap32

[GLOBAL: userInfoPane.html]
tap32
  • Contributor

  • 235 posts
  • Corona SDK

I just solved this myself by converting my keystore to a newer format in a new file and using that instead.

 

keytool -importkeystore -srckeystore mykeystore.keystore -destkeystore mykeystore.jks -deststoretype pkcs12 -destkeypass "password"

  • BK PANARA likes this

[TOPIC: post.html]
#8

BK PANARA

[GLOBAL: userInfoPane.html]
BK PANARA
  • Enthusiast

  • 57 posts
  • Corona SDK

 

I just solved this myself by converting my keystore to a newer format in a new file and using that instead.

keytool -importkeystore -srckeystore mykeystore.keystore -destkeystore mykeystore.jks -deststoretype pkcs12 -destkeypass "password"

I also can build successfully , but when i tried to install on my Android 8 device , i can see : Google Play protect popup with blocked message.

https://prnt.sc/o4w2ra
 




[topic_controls]
[/topic_controls]