Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Google 64-bit requirement for Corona Plugins
Started by troylyndon Jun 06 2019 09:49 AM

8 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

troylyndon

[GLOBAL: userInfoPane.html]
troylyndon
  • Contributor

  • 587 posts
  • Corona SDK

This thread is specific to 64-bit support/upgrades for plugins. If you want to read the core Corona SDK 64-bit forum thread, go here: https://forums.coronalabs.com/topic/74839-google-play-64-bit-requirement/

 

What information can anyone provide about a 64-bit version of these plugins?

 

     ["plugin.facebook.v4a"] = { publisherId = "com.coronalabs", },
     ["plugin.notifications.v2"] = { publisherId = "com.coronalabs" },
     ["plugin.gamecenter"] = { publisherId = "tech.scotth" },        -- This iOS system connectivity should have been published by Corona
     ["CoronaProvider.native.popup.social"] = { publisherId = "com.coronalabs" },
     ["CoronaProvider.native.popup.activity"] = { publisherId = "com.coronalabs", supportedPlatforms = { iphone=true } },
     ["plugin.google.iap.v3"] = { publisherId = "com.coronalabs", supportedplatforms = { android=true } },
     ["plugin.amazon.iap"] = { publisherid = "com.coronalabs", supportedplatforms = { ["android-kindle"]=true }},
     ["plugin.utf8"] = { publisherid = "com.coronalabs" },
     ["plugin.kochava"] = { publisherId = "com.coronalabs", },

     ["plugin.pasteboard"] = { publisherid = "com.coronalabs" }
     ["plugin.reviewPopUp"]={publisherId = "tech.scotth"},    -- This iOS system connectivity should have been published by Corona
     ["plugin.firebaseAnalytics"] = {publisherId = "tech.scotth",},  --this is incompatible with Corona's notificationsV2

     ["plugin.contacts"] = { publisherid = "tech.scotth", supportedplatforms = { iphone=true, android=true } },

     ['plugin.texttospeech'] = { publisherid = 'com.spiralcodestudio' },
      --['plugin.coronasplashcontrol'] = { publisherid = 'com.coronalabs' },  --is this deprecated?
   



[TOPIC: post.html]
#2

Scott Harrison

[GLOBAL: userInfoPane.html]
Scott Harrison
  • Corona Geek

  • 1,792 posts
  • Enterprise

I find about the info the same way everyone else does. I will update "all" plugins (that are on the corona plugin marketplace) to support 64-bit 

 

I am waiting for corona labs to push an official statement or document for plugin developers or a least in till corona supports 64-bit apps.

 

I cannot speak for other developers.



[TOPIC: post.html]
#3

troylyndon

[GLOBAL: userInfoPane.html]
troylyndon
  • Contributor

  • 587 posts
  • Corona SDK

@Rob, did you see what Scott said? "I am waiting for corona labs to push an official statement or document for plugin developers or a least in till corona supports 64-bit apps."



[TOPIC: post.html]
#4

Scott Harrison

[GLOBAL: userInfoPane.html]
Scott Harrison
  • Corona Geek

  • 1,792 posts
  • Enterprise

I know I can edit but just want to say I meant documentation. It going to talk a lot of work to go through all plugins and just rebuild. I want to make sure it is done right.



[TOPIC: post.html]
#5

umalemon

[GLOBAL: userInfoPane.html]
umalemon
  • Contributor

  • 101 posts
  • Corona SDK

Hello!
I use the following plugins.
 
plugins = {
["plugin.vibrator"] = { publisherId = "com.spiralcodestudio" },
["plugin.google.iap.v3"] = { publisherId = "com.coronalabs", supportedPlatforms = { android=true, ["android-kindle"]=false }},
["plugin.amazon.iap"] = { publisherId = "com.coronalabs", supportedPlatforms = { ["android-kindle"]=true }, },
["plugin.zip"] = { publisherId = "com.coronalabs", },
["plugin.twitter"] = { publisherId = "com.jasonschroeder",},
["plugin.facebook.v4a"] = { publisherId = "com.coronalabs" },
["plugin.notifications"] = { publisherId = "com.coronalabs" },
["plugin.googleSignIn"] = { publisherId = "tech.scotth", },
And uses "Appodeal(beta)", "ParticleCandy".
I am concerned about products that have not been updated for a long time, like "ParticleCandy".


[TOPIC: post.html]
#6

Lava Level

[GLOBAL: userInfoPane.html]
Lava Level
  • Contributor

  • 274 posts
  • Corona SDK

I think that would be best resolved with the actual 3rd party maker. I would suggest hitting the docs and build in Corona particles. They're pretty easy to get going and design with Particle Designer 2.



[TOPIC: post.html]
#7

Lerg

[GLOBAL: userInfoPane.html]
Lerg
  • Contributor

  • 535 posts
  • Corona Staff

Texttospeech plugin does not need to be recompiled, it's pure Java.


  • Lava Level likes this

[TOPIC: post.html]
#8

troylyndon

[GLOBAL: userInfoPane.html]
troylyndon
  • Contributor

  • 587 posts
  • Corona SDK

@Rob, can you please respond to my original post above, and let me know which of the plugins are expected to be converted before the end-of-July deadline?



[TOPIC: post.html]
#9

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,684 posts
  • Enterprise

As far as I know all of the plugins are good to go with maybe the exception of any "Fire*" plugins from Scott. In the chatter in #Android64 on the community slack, I think it works, if you include another plugin. But I cannot confirm any third-party plugin. If it doesn't say the publisherId is com.coronalabs, you need to just try and see and test.

 

The splash screen control is definitely not deprecated. You just don't need to include it in the plugins table. See: http://docs.coronalabs.com/plugin/CoronaSplashControl/index.html

 

Rob




[topic_controls]
[/topic_controls]