Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

build error 256 / key alias password can't be different from keystore password
Started by Dev-Ze.rocks Jun 01 2019 01:35 PM

2 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

Dev-Ze.rocks

[GLOBAL: userInfoPane.html]
Dev-Ze.rocks
  • Contributor

  • 213 posts
  • Corona SDK

Hei there.

It has been a while and I have to publish a new version of one of my apps or google will remove it from the store because of some vulnerablity...

 

So I just build the app again with the latest daily build (2019.3476) and it installed and runs fine when using the debug keystore.

But when using my own keystore I get "build error: 256". After some tests I was lucky to insert the same password for the keystore and the key alias and I am able to build normally.

 

When I first built the app I used a different password for the keystore and for the alias and it worked.

But now it seams that it is not more working this way. Is this something new? Will it stay this way? If so, it would be good to update the documentation...

 

I am on a Mac (10.14.4) and Xcode is 10.2.1, if this matters.

 

Best,

Felix



[TOPIC: post.html]
#2

XeduR @Spyric

[GLOBAL: userInfoPane.html]
XeduR @Spyric
  • Contributor

  • 731 posts
  • Corona SDK

Just to make sure that I am understanding you correctly. You've built and submitted an app to Google Play using a specific KeyStore, but now you've lost that KeyStore and you are trying to build and submit that same app to Google Play using a new KeyStore?

If so, then this is the intended behaviour to protect your app(s). Without the correct KeyStore and password, you won't be able to build. So, if you've lost your old KeyStore, then you are out of luck. If you've lost the KeyStore's password, you could try brute forcing or guessing, but most likely you are still out of luck.

 

You might want to read: https://stackoverflow.com/questions/6089813/how-to-handle-a-lost-keystore-password-in-android



[TOPIC: post.html]
#3

Dev-Ze.rocks

[GLOBAL: userInfoPane.html]
Dev-Ze.rocks
  • Contributor

  • 213 posts
  • Corona SDK

Hei XeduR,

thanks for the reply.

 

No, I have the keystore and I have the keystore password, and I also have the key (alias) password.

 

The thing is, that when I built the app the last time, I used a different password for the keystore and the alias, but this doesn't seam to work anymore.

But when I change the alias password to be the same as the keystore password, I get the build completed.

 

Hope this was clearer now.

 

Best,

Felix




[topic_controls]
[/topic_controls]