Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Problem with store & purchases (iOS)
Started by beernathan May 14 2019 03:07 AM

5 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

beernathan

[GLOBAL: userInfoPane.html]
beernathan
  • Contributor

  • 357 posts
  • Corona SDK

We're seeing some weird behaviour around store calls (iPhone XR, iPhone6) - it appears to not be running some commands that it should be - e.g. a print statement in main.lua doesn't get logged to the console when it runs (which is just before the call to load the store). It's also been unable to load the store with our code that runs fine on all the other Apple devices we've tested.

 

We get a response from the product listing, which is super weird as the logs indicate that the store init didn't even run, but any calls to Restore Purchases just seem to be ignored.

 

We're running on Corona 3468 and we're really stuck. Any ideas @robmiracle ?



[TOPIC: post.html]
#2

beernathan

[GLOBAL: userInfoPane.html]
beernathan
  • Contributor

  • 357 posts
  • Corona SDK

We've now got Android users with the same problem - not limited to iOS.



[TOPIC: post.html]
#3

beernathan

[GLOBAL: userInfoPane.html]
beernathan
  • Contributor

  • 357 posts
  • Corona SDK

On iOS the logs are showing some weird iTunes stuff when it tries to restore purchase:

 

PurchaseProtocolDataProvider: Error handler resolved with type: 0

PurchaseProtocolDataProvider: Error processing protocol: Error Domain=SSErrorDomain Code=16 "Cannot connect to iTunes Store" UserInfo={NSLocalizedDescription=Cannot connect to iTunes Store}



[TOPIC: post.html]
#4

SGS

[GLOBAL: userInfoPane.html]
SGS
  • Corona Geek

  • 2,120 posts
  • Corona SDK

Cannot connect to iTunes Store is either poor internet or jail broken device.  Either way you're not getting paid.  Had this for years...



[TOPIC: post.html]
#5

beernathan

[GLOBAL: userInfoPane.html]
beernathan
  • Contributor

  • 357 posts
  • Corona SDK

Hmmm, happens on a device I own (which is legit) with this app too.



[TOPIC: post.html]
#6

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,053 posts
  • Enterprise

Have you researched the problem on Google? It may be systemic to those devices. There's likely something in the Apple forums about it. We are unaware of any changes to the store code needed for those devices.

 

Rob




[topic_controls]
[/topic_controls]