Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Build Error Trying to use Custom Splash Screen
Started by davidgmonical May 09 2019 04:45 PM

5 replies to this topic

Best Answer davidgmonical , 10 May 2019 - 09:09 PM

Ah so it turns out my splash screen image was too big. I made the long side of it 1536 pixels, and now it's building!

[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

davidgmonical

[GLOBAL: userInfoPane.html]
davidgmonical
  • Enthusiast

  • 84 posts
  • Corona SDK

Hi,

 

I just bought the splash screen control plugin.

 

I put this in my build.settings

splashScreen = 
    {
        enable = true,
        image = "splashScreen.png"
    },

And a splashScreen.png in my resource directory.

 

The build succeeds if I take that out of the build.settings, but fails if it's in.

Am I missing something to be able to use custom splash screen?

 

Thanks



[TOPIC: post.html]
#2

SGS

[GLOBAL: userInfoPane.html]
SGS
  • Corona Geek

  • 2,024 posts
  • Corona SDK

mine looks like this and works fine

  splashScreen =
  {
    ios = {
      enable = true,
      image = "splash_ios.png"
    },
    android = {
      enable = true,
      image = "splash_android.png"
    }
  },


[TOPIC: post.html]
#3

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,546 posts
  • Enterprise

When you say it fails, can you provide the message you're getting?

 

Rob



[TOPIC: post.html]
#4

davidgmonical

[GLOBAL: userInfoPane.html]
davidgmonical
  • Enthusiast

  • 84 posts
  • Corona SDK

@SGS, just tried that replacing both image file names with "splashScreen.png". Same error building.

 

@Rob, is there a way to see more detailed error messages? The simulator terminal is giving me this

 

 
May 11 04:39:27.578 ERROR: build failed
                                   There was a problem completing the build on the server
May 11 04:39:27.579 
May 11 04:39:27.607 iOS build failed (11) after 107 seconds
May 11 04:39:27.913 ERROR: Build Failed: ERROR: build failed
                                   There was a problem completing the build on the server


[TOPIC: post.html]
#5

davidgmonical

[GLOBAL: userInfoPane.html]
davidgmonical
  • Enthusiast

  • 84 posts
  • Corona SDK

  Best Answer

Ah so it turns out my splash screen image was too big. I made the long side of it 1536 pixels, and now it's building!



[TOPIC: post.html]
#6

SGS

[GLOBAL: userInfoPane.html]
SGS
  • Corona Geek

  • 2,024 posts
  • Corona SDK

How big were your images?  I use 1080x1920 and 2048x2732.




[topic_controls]
[/topic_controls]