Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Build for Android crashes simulator
Started by fernandoluisbarros Apr 22 2019 06:06 AM

1 reply to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

fernandoluisbarros

[GLOBAL: userInfoPane.html]
fernandoluisbarros
  • Observer

  • 1 posts
  • Corona SDK

Hello first time Corona user here.

 

So after successfully reading through the first part of the "Getting started" steps, I could see a nice little balloon in my simulator. At which point I decided to see how it would look on my Android phone, and that's when all the drama started.

 

System information:

CPU: i7-7700HQ

GPU: Nvidia GeForce GTX 1070

RAM: 16Gb

 

OS: Windows 10 

JDK: 1.8.0_211 (x86)

JRE: 1.8.0_211 (x86)

 

All drivers fully up to date

 

The issue:

The Simulator will crash/exit when building for android, with the console displaying only the following:

 

15:49:21.014  Copyright © 2009-2018  C o r o n a   L a b s   I n c .
15:49:21.014  Version: 3.0.0
15:49:21.014  Build: 2018.3326
15:49:21.014  Platform: SM-G900S / x64 / 10.0 / GeForce GTX 1070/PCIe/SSE2 / 4.6.0 NVIDIA 425.31 / 2018.3326 / pt_PT | PT | pt_PT | pt
15:49:21.014  Loading project from:   C:\Users\ferna\Documents\Corona Projects\Test
15:49:21.014  Project sandbox folder: C:\Users\ferna\AppData\Local\Corona Labs\Corona Simulator\Sandbox\test-519088410A83EEF7508289FC65E4BD61\Documents
15:49:57.805  Testing credentials for 'D:\work\tools\Corona Labs\Corona\Resources\debug.keystore': 
15:50:00.074  The stdin connection has closed.
 
As far as I can tell this crash will occur a random points always seemingly related to the keystore.
Sometimes it will crash during the pre-build dialog popup while selecting a keystore, other times after confirming information in said dialog.
 
Troubleshooting done:
Tested the following corona version all yielding the same result:
 - Corona-2018.3326
 - Corona-2019.3471
 
Tested uninstalling corona from custom folder, clearing all other related files manually, rebooting, installing stable corona in default path. Yielded same result.
 
Tested generating my own keystore instead of using default corona keystore. Crash consistently happening when inputing password, either at input time or after dismissal when choosing alias.
 
Tested x64 JDK/JRE. Same result.
 
Tested disabling ESET smart security firewall. Same result.
 
Additional remarks:
This machine is currently properly setup to execute builds on Unity, Unreal, Cordova, Cocos2dx and native android build, so maybe I have something setup that is incompatible with Corona SDK ?
 
To be fair, I'm completely lost here. I've attempted to attach crash dump files of the 2 types of crashes I isolated but the forum system does not allow me to do so (6384 and 16360 seem to be the error codes of these crashes ?)
 
Would appreciate some help troubleshooting this.
 
Cheers,
Fernando
 


[TOPIC: post.html]
#2

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 654 posts
  • Corona Staff

Did you manage to start a build, or crash occurs before the build when you're selecting keystore? Corona invokes Java process, it just runs some java commands. I think this is what causing the crash, but pinpointing it would be very hard. If it happens during actual build, you can run this command, so it will print out detailed log of what's going on:

reg ADD "HKEY_CURRENT_USER\Software\Ansca Corona\Corona Simulator\Preferences" /f /v debugBuildProcess /d 3



[topic_controls]
[/topic_controls]