Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Build error 5
Started by mysticeti Apr 17 2019 03:31 AM

27 replies to this topic
build error 5 build error android

Best Answer vlads , 08 May 2019 - 03:05 PM

Or VPN, if you're in Russia, we has issues with government blocking stuff.

[TOPIC CONTROLS]
Page 1 of 2 1 2
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

mysticeti

[GLOBAL: userInfoPane.html]
mysticeti
  • Contributor

  • 122 posts
  • Corona SDK

Hi

I am using 2019.3474

I have tried for last 2 days and I am getting the same build error message. I have also tried by repairing the installation and the problem still persists. I built corona apps before using the same pc.

Using custom Build Id 00000
Excluding specified files from build: 
   excluding: Icon.png
   excluding: Icon-Small-*.png
   excluding: Icon*@2x.png
BuildID: 5cb70d371e96a
WebServices: downloading build
ERROR: download failed to open URL: The operation timed out
ERROR: failed to download build: http://builds.coronalabs.com/5cb70d371e96a-built.zip?AWSAccessKeyId=ACCESS KEY VALUE &Expires=1555500479&Signature=SIGNATURE VALUE


ERROR: download failed to open URL: The operation timed out
Android build failed (5) after 142 seconds

Is anyone facing the same issue or know what could be the issue?

Thanks in advance



[TOPIC: post.html]
#2

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Corona Geek

  • 1,130 posts
  • Corona SDK

I am using 3470 and I built yesterday multiple times without any issues. Do you have a firewall somewhere or anything else that might be blocking the coronalabs url?



[TOPIC: post.html]
#3

mysticeti

[GLOBAL: userInfoPane.html]
mysticeti
  • Contributor

  • 122 posts
  • Corona SDK

@agramonte

I recently changed place. I will try in a different network connection.
 



[TOPIC: post.html]
#4

1305046.ab

[GLOBAL: userInfoPane.html]
1305046.ab
  • Observer

  • 1 posts
  • Corona SDK

I am also getting the same error. I did not get the error 2-3 days back. What should I do?

I am using my usual setting.



[TOPIC: post.html]
#5

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,648 posts
  • Enterprise

Post your build.settings

Post your entire console log from a build that is failing



[TOPIC: post.html]
#6

mysticeti

[GLOBAL: userInfoPane.html]
mysticeti
  • Contributor

  • 122 posts
  • Corona SDK

NOTE: I still didn't check whether my build is successful in another network connection. I will try out at the end of this month.

 

This is my current settings and response i get.
build.settings

--
-- For more information on build.settings see the Corona SDK Build Guide at:
-- https://docs.coronalabs.com/guide/distribution/buildSettings
--


settings =
{
orientation =
{
-- Supported values for orientation:
-- portrait, portraitUpsideDown, landscapeLeft, landscapeRight


default = "portrait",
supported = { "portrait", },
},


excludeFiles =
{
-- Include only the necessary icon files on each platform
iphone = { "Icon-*dpi.png", },
android = { "Icon.png", "Icon-Small-*.png", "Icon*@2x.png", },
},
  
--
-- Android Section
--
android =
{
usesPermissions =
{
"android.permission.INTERNET",
      "android.permission.ACCESS_COARSE_LOCATION",
      "android.permission.ACCESS_NETWORK_STATE",
      "android.permission.ACCESS_FINE_LOCATION",
      "com.android.vending.CHECK_LICENSE",
      "android.permission.VIBRATE",
      "android.permission.WRITE_EXTERNAL_STORAGE",
      "android.permission.GET_ACCOUNTS",
      "com.android.vending.BILLING",
    
},
    
    googlePlayGamesAppId = "VALUE HERE",


  },
  
   plugins =
      {
        
        ["CoronaProvider.native.popup.social"] =
        {
            publisherId = "com.coronalabs"
        },
        ["plugin.gpgs.v2"] = 
        {
            publisherId = "com.coronalabs",
            supportedPlatforms = { ["android"] = true }
        },
        ['plugin.toast'] = 
        {
        publisherId = 'com.spiralcodestudio'
        },
        ["plugin.google.iap.v3"] =
        {
            publisherId = "com.coronalabs"
        },
        
        ['plugin.appodeal.beta.base'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.AdColony'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.AppLovin'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.Chartboost'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.Flurry'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.GoogleAdMob'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.InMobi'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.IronSource'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.Mobvista'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.MyTarget'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.Ogury'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.StartApp'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.TwitterMoPub'] = { publisherId = 'com.coronalabs' },


      }
}       

Error output 

Testing credentials for 'E:\xto.keystore': 
Picked up JAVA_TOOL_OPTIONS: -Duser.language=en
jar signed.


Warning: 
The signer's certificate is self-signed.
Using custom build id from app bundle: 00000 (AppSettings.lua)


Using custom Build Id 00000
Excluding specified files from build: 
   excluding: Icon.png
   excluding: Icon-Small-*.png
   excluding: Icon*@2x.png
BuildID: 5cb970d42a07e
WebServices: downloading build
ERROR: download failed to open URL: The operation timed out
ERROR: failed to download build: http://builds.coronalabs.com/5cb970d42a07e-built.zip?AWSAccessKeyId=VALUE HERE&Expires=1555657050&Signature=VALUE HERE


ERROR: download failed to open URL: The operation timed out
Android build failed (5) after 140 seconds


[TOPIC: post.html]
#7

marketplace

[GLOBAL: userInfoPane.html]
marketplace
  • Observer

  • 7 posts
  • Corona Staff

I'm checking with the team to see if they are aware of any issues. I just did builds for Android and iOS and didn't see any errors, so maybe it's a connectivity problem.

 

You can always try building sample apps and see if that works, comment out various plugins to see if one of them may be the particular problem.

 

Rob


  • mysticeti likes this

[TOPIC: post.html]
#8

mysticeti

[GLOBAL: userInfoPane.html]
mysticeti
  • Contributor

  • 122 posts
  • Corona SDK

Hi

@Rob
Thank you for the suggestion. 

I have rechecked with building the included sample app for animation and the build was fine. I didn't get any errors so I found that network isn't the issue. 

I have tried commenting out the beta.appodeal plugin and the build was working. I think there is some issue with the appodeal plugin build. I have tried including only the 3 beta base plugins but still I was getting the same build error 5 and I have also tried only the release 3 base plugins and still was getting the error.

['plugin.appodeal.beta.base'] = { publisherId = 'com.coronalabs' },
['plugin.appodeal.beta.GoogleAdMob'] = { publisherId = 'com.coronalabs' },
['plugin.appodeal.beta.StartApp'] = { publisherId = 'com.coronalabs' },

If you could please check what might be the issue regarding the appodeal plugin



[TOPIC: post.html]
#9

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Corona Geek

  • 1,130 posts
  • Corona SDK

Just built my app for Android and iOS using .3470 using my usual appodeal configuration and it worked. Can you try removing StartApp?

 

 

-- Appodeal

        ['plugin.appodeal.beta.base'] = { 
            publisherId = 'com.coronalabs',
            supportedPlatforms = { iphone=true, android=true }
        },
        ['plugin.appodeal.beta.FacebookAudience'] = { 
            publisherId = 'com.coronalabs',
            supportedPlatforms = { iphone=true, android=true }
        },
        ['plugin.appodeal.beta.AmazonAds'] = { 
            publisherId = 'com.coronalabs',
            supportedPlatforms = { iphone=true, android=true }
        },
        ['plugin.appodeal.beta.GoogleAdMob'] = { 
            publisherId = 'com.coronalabs',
            supportedPlatforms = { iphone=true, android=true }
        }

 

 

"iPhone Developer: Adrian Gomez (xxxx)"

Apr 20 09:43:20.811 iOS build succeeded in 113 seconds

 

Apr 20 09:37:41.660 Using java version "1.8.0_151"

                    Java™ SE Runtime Environment (build 1.8.0_151-b12)
                    Java HotSpot™ 64-Bit Server VM (build 25.151-b12, mixed mode)
Apr 20 09:37:42.492 Building Android app for xxxxx with 2019.3470
Apr 20 09:37:43.924 Using custom build id from app bundle: 00000 (AppSettings.lua)
Apr 20 09:37:45.282 BUILD SUCCESSFUL
                    Total time: 0 seconds
Apr 20 09:39:05.818 Excluding specified files from build: 
                       excluding: LaunchScreen.storyboardc
                       excluding: Icon.png
                       excluding: Icon-*dpi.png
                       excluding: Images.xcassets
                    BuildID: 5cbb20ba1f850
Apr 20 09:39:13.006      [echo]  "creating unsigned.apk" 
Apr 20 09:39:13.007 
Apr 20 09:39:16.567 BUILD SUCCESSFUL
                    Total time: 6 seconds
Apr 20 09:39:16.660 Android build succeeded in 92 seconds


[TOPIC: post.html]
#10

mysticeti

[GLOBAL: userInfoPane.html]
mysticeti
  • Contributor

  • 122 posts
  • Corona SDK

@agramonte

Thank you for the suggestion.

I have tried checking individual plugins and found that only this following combination works but sometimes the build would fail, but by restarting the simulator the build was again successful:

NOTE: sometimes mytarget plugin would give a successful build.

 

Working

['plugin.appodeal.beta.base'] = { publisherId = 'com.coronalabs' },
['plugin.appodeal.beta.GoogleAdMob'] = { publisherId = 'com.coronalabs' },

BUT if I included any of the following plugins I get the build error:

 

Not Working

      --  ['plugin.appodeal.beta.AdColony'] = { publisherId = 'com.coronalabs' },
      --  ['plugin.appodeal.beta.AppLovin'] = { publisherId = 'com.coronalabs' },
      --  ['plugin.appodeal.beta.AmazonAds'] = { publisherId = 'com.coronalabs' },
      --  ['plugin.appodeal.beta.Chartboost'] = { publisherId = 'com.coronalabs' },
       -- ['plugin.appodeal.beta.Flurry'] = { publisherId = 'com.coronalabs' },
       -- ['plugin.appodeal.beta.InMobi'] = { publisherId = 'com.coronalabs' },
       -- ['plugin.appodeal.beta.IronSource'] = { publisherId = 'com.coronalabs' },
       -- ['plugin.appodeal.beta.Mobvista'] = { publisherId = 'com.coronalabs' },
        --['plugin.appodeal.beta.MyTarget'] = { publisherId = 'com.coronalabs' },
       -- ['plugin.appodeal.beta.Ogury'] = { publisherId = 'com.coronalabs' },
       -- ['plugin.appodeal.beta.StartApp'] = { publisherId = 'com.coronalabs' },
       -- ['plugin.appodeal.beta.TwitterMoPub'] = { publisherId = 'com.coronalabs' },


[TOPIC: post.html]
#11

marketplace

[GLOBAL: userInfoPane.html]
marketplace
  • Observer

  • 7 posts
  • Corona Staff

Is there a reason you're using the beta version?



[TOPIC: post.html]
#12

mysticeti

[GLOBAL: userInfoPane.html]
mysticeti
  • Contributor

  • 122 posts
  • Corona SDK

@Rob

Yes, I am using the beta version for the hasUserConsent parameter in appodeal.init(), for the GDPR compliance.



[TOPIC: post.html]
#13

mysticeti

[GLOBAL: userInfoPane.html]
mysticeti
  • Contributor

  • 122 posts
  • Corona SDK

Hi

Is there any update on this issue? I have tried rebuilding in 2019.3476 and still getting the same error. Only if I include these plugin then there aren't any issue. But I if I include other parts of the appodeal beta plugin, the error persists. 

['plugin.appodeal.beta.base'] = { publisherId = 'com.coronalabs' },
['plugin.appodeal.beta.GoogleAdMob'] = { publisherId = 'com.coronalabs' },


[TOPIC: post.html]
#14

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 667 posts
  • Corona Staff

Please, try again: I just tried to build with all the Appodeal plugins, it worked fine. We had build server issues before



[TOPIC: post.html]
#15

mysticeti

[GLOBAL: userInfoPane.html]
mysticeti
  • Contributor

  • 122 posts
  • Corona SDK

Thank you for looking into this issue while being busy with the major upgrade of corona build system.

Now the build works fine with the following modules: 

['plugin.appodeal.beta.base'] = { publisherId = 'com.coronalabs' },
['plugin.appodeal.beta.Chartboost'] = { publisherId = 'com.coronalabs' },
['plugin.appodeal.beta.GoogleAdMob'] = { publisherId = 'com.coronalabs' },

But if I include any of the following modules I get the same build error 5:

['plugin.appodeal.beta.AdColony'] = { publisherId = 'com.coronalabs' },
['plugin.appodeal.beta.AmazonAds'] = { publisherId = 'com.coronalabs' },
['plugin.appodeal.beta.Flurry'] = { publisherId = 'com.coronalabs' },
['plugin.appodeal.beta.InMobi'] = { publisherId = 'com.coronalabs' },
['plugin.appodeal.beta.IronSource'] = { publisherId = 'com.coronalabs' },
['plugin.appodeal.beta.MyTarget'] = { publisherId = 'com.coronalabs' },
['plugin.appodeal.beta.Ogury'] = { publisherId = 'com.coronalabs' },
['plugin.appodeal.beta.StartApp'] = { publisherId = 'com.coronalabs' },


[TOPIC: post.html]
#16

mysticeti

[GLOBAL: userInfoPane.html]
mysticeti
  • Contributor

  • 122 posts
  • Corona SDK

Update

I am getting build error 5 for even the sample codes with debug keystore. I am using jdk 12.0.1

 

Here is the message I get

 

Copyright (C) 2009-2019  C o r o n a   L a b s   I n c .
Version: 3.0.0
Build: 2019.3476
Platform: GenericAndroidDevice / x64 / 10.0 / Intel(R) UHD Graphics 630 / 4.5.0 - Build 25.20.100.6446 / 2019.3476 / en_US | US | en_US | en
Loading project from:   C:\Program Files (x86)\Corona Labs\Corona\Sample Code\Physics\Bridge
Project sandbox folder: C:\Users\er\AppData\Local\Corona Labs\Corona Simulator\Sandbox\bridge-8B5B7E0F39DDDA034080FD0DF6A81F5A\Documents
Testing credentials for 'D:\erw\Security\debug.keystore': 
Picked up JAVA_TOOL_OPTIONS: -Duser.language=en
jar signed.


Warning: 
The signer's certificate is self-signed.


The timestamp will expire on 2028-01-18.
Using custom build id from app bundle: 00000 (AppSettings.lua)


Using custom Build Id 00000
BuildID: 5ccf0719bf499
WebServices: downloading build
ERROR: download failed to open URL: The operation timed out
ERROR: failed to download build: http://builds.coronalabs.com/5ccf0719bf499-built.zip?AWSAccessKeyId=AKIAIMSD7JG23DSGPRIA&Expires=1557071691&Signature=qpHM9zDrBra3rEn1iyqT5%2BqL8Xk%3D


ERROR: download failed to open URL: The operation timed out
Android build failed (5) after 53 seconds


[TOPIC: post.html]
#17

mysticeti

[GLOBAL: userInfoPane.html]
mysticeti
  • Contributor

  • 122 posts
  • Corona SDK

Update
 

Builds are working fine now. 

But the appodeal plugin still remains an issue. Now if I inlcude chartboost plugin the build fails. Now with these plugins build works, I have tested them around 5 times and the build were successful.

 

 ['plugin.appodeal.beta.base'] = { publisherId = 'com.coronalabs' },
 ['plugin.appodeal.beta.AdColony'] = { publisherId = 'com.coronalabs' },
 ['plugin.appodeal.beta.GoogleAdMob'] = { publisherId = 'com.coronalabs' },

Only when I include the following plugins the build fails:

 

        ['plugin.appodeal.beta.AmazonAds'] = { publisherId = 'com.coronalabs' },
       ['plugin.appodeal.beta.Chartboost'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.FacebookAudience'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.Flurry'] = { publisherId = 'com.coronalabs' },
       ['plugin.appodeal.beta.InMobi'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.IronSource'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.MyTarget'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.Ogury'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.StartApp'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.beta.TwitterMoPub'] = { publisherId = 'com.coronalabs' },
        

I have tested including one plugin at a time to see which one causes the build to fail.



[TOPIC: post.html]
#18

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,648 posts
  • Enterprise

Can you run this command from the command line and try your build again? You will need to quit and relaunch the simulator. This may provide more information in the console log from the build.

 

reg ADD "HKEY_CURRENT_USER\Software\Ansca Corona\Corona Simulator\Preferences" /f /v debugBuildProcess /d 3

 

Rob



[TOPIC: post.html]
#19

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Corona Geek

  • 1,130 posts
  • Corona SDK

If also send the project I can try and build it. I have built a couple projects the last few days and don't have this problem. Actually other than that period of time where the builds were broken for a few days, I have never had this issue.



[TOPIC: post.html]
#20

mysticeti

[GLOBAL: userInfoPane.html]
mysticeti
  • Contributor

  • 122 posts
  • Corona SDK

@agramonte

 

Thank you very much for willing to help me. I will build a test project with all the same build settings and message you personally with the project.



[TOPIC: post.html]
#21

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Corona Geek

  • 1,130 posts
  • Corona SDK

I was able to build with your sample project and all the appodeal plugins both for iOS and Android. I recorded otherwise I have no proof it happened:

 

https://youtu.be/adCQf8Okfgc



[TOPIC: post.html]
#22

mysticeti

[GLOBAL: userInfoPane.html]
mysticeti
  • Contributor

  • 122 posts
  • Corona SDK

@agramonte

 

Thank you for testing it out. I don't know why sometimes I can built but as of right now I can't build the app again at all..getting the same build error and also getting a new error. I can't build the sample projects also now.
 

Build error #1, I get this error sometime when I was testing today, but if I just relaunch the simulator and start another build then build error 5 comes.

BUILD FAILED
C:\Program Files (x86)\Corona Labs\Corona\Resources\build.xml:85: Error while expanding C:\Users\UserK~1\AppData\Local\Temp\Corona Labs\CLtmpa37004\output.zip
java.io.IOException: Negative seek offset
at java.base/java.io.RandomAccessFile.seek(RandomAccessFile.java:591)
at org.apache.tools.zip.ZipFile.positionAtCentralDirectory(ZipFile.java:467)
at org.apache.tools.zip.ZipFile.populateFromCentralDirectory(ZipFile.java:313)
at org.apache.tools.zip.ZipFile.<init>(ZipFile.java:185)
at org.apache.tools.ant.taskdefs.Expand.expandFile(Expand.java:170)
at org.apache.tools.ant.taskdefs.Expand.execute(Expand.java:132)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.base/java.lang.reflect.Method.invoke(Method.java:567)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:390)
at org.apache.tools.ant.Target.performTasks(Target.java:411)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1397)
at org.apache.tools.ant.Project.executeTarget(Project.java:1366)
at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
at org.apache.tools.ant.Project.executeTargets(Project.java:1249)
at org.apache.tools.ant.Main.runBuild(Main.java:801)
at org.apache.tools.ant.Main.startAnt(Main.java:218)
at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)


Total time: 0 seconds
Android build failed (1) after 80 seconds

I have tried disabling antivirus and windows firewall but the problem persists. 

I will check in another network connection this friday, just to rule out any network related issue, since downloading (operation time out) seems to be the problem.

My current setup is windows 10, jdk 12.0.1 from oracle, corona 2019.3476. I have android studio installed also 3.4 and since it comes with its own openjdk i don't know whether there could be any conflict or not. 

 



[TOPIC: post.html]
#23

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,648 posts
  • Enterprise

I know it feels important to obscure private data but perhaps that's where the problem lies. Corona sometimes has issues with weird paths, UTF-8 characters,  things split between the C: drive and other drives and network drives. Perhaps in you're obscuring something important that can be used to diagnose the issue.

 

Since this appears to be local to you, we should focus on path related things. I would suggest making a clean path with no spaces, no UTF-8 characters, maybe c:\projects\test you can also try to create a new user with no spaces in the name and try keeping everything on C:

 

Rob



[TOPIC: post.html]
#24

mysticeti

[GLOBAL: userInfoPane.html]
mysticeti
  • Contributor

  • 122 posts
  • Corona SDK

I have created a new user with administrator rights in my pc. I have reinstalled jdk also. I am trying to build the sample project without any modification with debug keystore but I am getting the same error. Here is the full console log unedited.
 

Program starting as '"C:\Program Files (x86)\Corona Labs\Corona\Corona Simulator.exe" -no-console -debug "C:\Program Files (x86)\Corona Labs\Corona\Sample Code\Physics\Bullet\main.lua"'.
Program 'Corona Simulator.exe' started in 'C:\Program Files (x86)\Corona Labs\Corona\Sample Code\Physics\Bullet' (pid: 12168).


Corona Simulator 2019.3476 (Apr 22 2019 19:03:02)




Copyright (C) 2009-2019  C o r o n a   L a b s   I n c .
Version: 3.0.0
Build: 2019.3476
Platform: GenericAndroidDevice / x64 / 10.0 / Intel(R) UHD Graphics 630 / 4.5.0 - Build 25.20.100.6446 / 2019.3476 / en_US | US | en_US | en
Loading project from:   C:\Program Files (x86)\Corona Labs\Corona\Sample Code\Physics\Bullet
Project sandbox folder: C:\Users\Omar\AppData\Local\Corona Labs\Corona Simulator\Sandbox\bullet-FA017BB13E0E57A076591E5E2F561BF1\Documents
Testing credentials for 'C:\sheekore\Security\debug.keystore': 
Picked up JAVA_TOOL_OPTIONS: -Duser.language=en
jar signed.


Warning: 
The signer's certificate is self-signed.


The timestamp will expire on 2028-01-18.
Using custom build id from app bundle: 00000 (AppSettings.lua)


Using custom Build Id 00000
Prepackage: Compiling Lua ...
Prepackage: Building server data file
Prepackage: running: "C:\Program Files\Java\jdk-12.0.1\bin\java.exe" -Djava.class.path="C:\Program Files (x86)\Corona Labs\Corona\Resources/ant.jar;C:\Program Files (x86)\Corona Labs\Corona\Resources/ant-launcher.jar;C:\Program Files (x86)\Corona Labs\Corona\Resources/AntLiveManifest.jar" org.apache.tools.ant.launch.Launcher -v -DTEMP_DIR="C:\Users\Omar\AppData\Local\Temp\Corona Labs\CLtmpa14240" -DSRC_DIR="C:\Program Files (x86)\Corona Labs\Corona\Sample Code\Physics\Bullet" -DBUNDLE_DIR="C:\Program Files (x86)\Corona Labs\Corona\Resources" -DLIVE_BUILD=NO -DLIVE_BUILD_MANIFEST_FILE= -f "C:\Program Files (x86)\Corona Labs\Corona\Resources"/build.xml build-input-zip
Picked up JAVA_TOOL_OPTIONS: -Duser.language=en
Apache Ant version 1.8.1 compiled on April 30 2010
Buildfile: C:\Program Files (x86)\Corona Labs\Corona\Resources\build.xml
Detected Java version: 1.6 in: C:\Program Files\Java\jdk-12.0.1
Detected OS: Windows 10
parsing buildfile C:\Program Files (x86)\Corona Labs\Corona\Resources\build.xml with URI = file:/C:/Program%20Files%20(x86)/Corona%20Labs/Corona/Resources/build.xml
Project base dir set to: C:\Program Files (x86)\Corona Labs\Corona\Resources
parsing buildfile jar:file:/C:/Program%20Files%20(x86)/Corona%20Labs/Corona/Resources/ant.jar!/org/apache/tools/ant/antlib.xml with URI = jar:file:/C:/Program%20Files%20(x86)/Corona%20Labs/Corona/Resources/ant.jar!/org/apache/tools/ant/antlib.xml from a zip file
 [property] Loading C:\Program Files (x86)\Corona Labs\Corona\Resources\build.properties
Override ignored for property "SRC_DIR"
Override ignored for property "SCRIPT_EXT"
 [macrodef] creating macro  copy-res-file
 [macrodef] creating macro  copy-drawable-file
 [macrodef] creating macro  copy-mipmap-file
 [macrodef] creating macro  copy-notification-icon
Build sequence for target(s) `build-input-zip' is [generate-live-build-manifest, build-input-zip]
Complete build sequence is [generate-live-build-manifest, build-input-zip, can-delete-file, unzip-apk-template, build-unsigned-apk, sign-apk-md5, sign-apk-sha1, can-copy-file, build-signed-apk, copy-files-to-apk, copy-apk-assets, test-sign, find-ouya-xiaomi-application-icon, insert-ouya-xiaomi-application-icon, copy-apk-to, sign-apk-auto, sign-apk, find-main-application-banner, insert-main-application-banner, find-main-application-icons, insert-main-application-icons, find-default-notification-icons, insert-default-notification-icons, insert-assets-multi-icon, build-expansion-file, copy-to, build, find-ouya-application-icon, insert-ouya-application-icon, copy-file, , delete-file]


generate-live-build-manifest:
Skipped because property 'live.build' not set.


build-input-zip:
      [zip] Building zip: C:\Users\Omar\AppData\Local\Temp\Corona Labs\CLtmpa14240\input.zip
      [zip] adding entry build.properties
      [zip] adding entry config.lu
      [zip] adding entry excludesfile.properties
      [zip] adding entry main.lu


BUILD SUCCESSFUL
Total time: 0 seconds
DeviceBuildData: {"isLaunchPadActive":false,"targetCertType":"distribution","targetPlatformVersion":140300,"debugBuildProcess":3,"targetDevice":0,"dailyBuildRevision":3476,"buildBucket":"ansca-templates","clientPlatform":"Win","targetAppStore":"google","targetPlatform":1,"clientDeviceId":"315175e9a5ca20c3d50ff1c4291de4bc","plugins":[],"dailyBuildYear":2019,"clientProductId":"basic","appName":"Bullet"}
BuildID: 5cd31660e97d8
WebServices: downloading build
ERROR: download failed to open URL: The operation timed out
ERROR: failed to download build: http://builds.coronalabs.com/5cd31660e97d8-built.zip?AWSAccessKeyId=AKIAIMSD7JG23DSGPRIA&Expires=1557337746&Signature=WODooPP7%2BD5ig8TMrk%2BhkNqkTj0%3D


ERROR: download failed to open URL: The operation timed out
Android build failed (5) after 52 seconds
Program completed in 107.64 seconds (pid: 12168).


[TOPIC: post.html]
#25

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Corona Geek

  • 1,130 posts
  • Corona SDK

To me this looks like some sort of network issue. Do you have a coffee shop somewhere you can take your machine and try to build from a different network?




[topic_controls]
Page 1 of 2 1 2
 
[/topic_controls]

Also tagged with one or more of these keywords: build error 5, build error, android