Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

ERROR: Admob not found Toast on Android Native with Appodeal
Started by Mars Interactive Apr 02 2019 03:17 AM

1 reply to this topic
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

Mars Interactive

[GLOBAL: userInfoPane.html]
Mars Interactive
  • Contributor

  • 181 posts
  • Corona SDK

Hello,

 

We've placed the modular version of Appodeal in our Native Android Build (After the all-inclusive one gave us an error of out of date plugins), and we are getting an Android toast saying: "ERROR: Admob not found".

 

We tried changing the Appodeal Plugin to the Beta version, but after Downloading -> Moving Jar files -> Setting up the manifest file, we are now getting the exact same error toast.

 

Looking into the downloaded Admob plugin, and it's pretty much empty. No metadata to copy over to manifest and no Jar file to copy either.

 

Please help,

Mor from Mars.



[TOPIC: post.html]
#2

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Corona Geek

  • 1,417 posts
  • Corona SDK

It is in the metadata of the base of Appodeal plugin: ["shared.google.play.services.ads"] = "com.coronalabs"

coronaManifest = {
		dependencies = {
			["shared.android.support.v4"] = "com.coronalabs",
			["shared.android.support.v7.appcompat"] = "com.coronalabs",
			["shared.android.support.v7.recyclerview"] = "com.coronalabs",
			["shared.google.play.services.ads"] = "com.coronalabs",
            ["shared.google.play.services.location"] = "com.coronalabs",
            ["shared.google.play.services.gcm"] = "com.coronalabs"
		}
	}



[topic_controls]
[/topic_controls]