Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Error at start-up using OneSignal Plugin
Started by agramonte Mar 04 2019 09:01 AM

3 replies to this topic
onesignal
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Corona Geek

  • 1,221 posts
  • Corona SDK

Every time my app starts I see this error in the console:

 

 

com.ansca.corona.notifications.GoogleCloudMessagingBroadcastReceiver does not exist 

 

It is the exact same error as in these older threads:

 

https://forums.coronalabs.com/topic/71936-javalangillegalargumentexception-component-class-comanscacoronanotificationsgooglecloudmessagingbroadcastreceiver-does-not-exist/

 

https://forums.coronalabs.com/topic/74098-googlecloudmessagingbroadcastreceiver-does-not-exist-error/

 

The workaround mentioned in the first link does not resolve the issue.

It does not appear to impact the app but not sure if it will create an ANR on the Google side.

 

Corona Version: 3468

Platform: PH-1 / ARM Neon / 9 / Adreno ™ 540 / OpenGL ES 3.2 V



[TOPIC: post.html]
#2

YouHome

[GLOBAL: userInfoPane.html]
YouHome
  • Observer

  • 18 posts
  • Corona SDK

You find solution for that?



[TOPIC: post.html]
#3

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Corona Geek

  • 1,221 posts
  • Corona SDK

Nope



[TOPIC: post.html]
#4

YouHome

[GLOBAL: userInfoPane.html]
YouHome
  • Observer

  • 18 posts
  • Corona SDK

In IOS it's working fine. But in Android don't work. It's a problem in my app.




[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: onesignal