Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Uploading to App Store
Started by lofy Feb 26 2019 10:34 AM

5 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

lofy

[GLOBAL: userInfoPane.html]
lofy
  • Enthusiast

  • 75 posts
  • Corona SDK

I am going to upload to the app store and I am getting this weird error. 

 

ERROR ITMS-90171: "Invalid Bundle Structure - The binary file 'Dragon Breaker - To Store.app/iphone/libplugin_gameanalytics_v2.a.orig' is not permitted. Your app can’t contain standalone executables or libraries, other than a valid CFBundleExecutable of supported bundles. Refer to the Bundle Programming Guide at https://developer.apple.com/go/?id=bundle-structure for information on the iOS app bundle structure."

settings = 
{
	orientation =
	{
		default = "portrait",
		supported = { "portrait" }
	},
  iphone =
    {
	         xcassets = "Images.xcassets",
        plist =
        {
            CFBundleIconFiles = {},  -- Required!
            UILaunchStoryboardName = "LaunchScreen",  -- Required!
            UIStatusBarHidden = true,
            CFBundleDisplayName = "Dragon Breaker",
            CFBundleName = "Dragon Breaker",
            
            UIApplicationExitsOnSuspend = false,
            FacebookAppID = "135961820318777",  -- Replace XXXXXXXXXX with your Facebook App ID
            CFBundleURLTypes =
            {
                { CFBundleURLSchemes = { "fb135961820318777", } }  -- Replace XXXXXXXXXX with your Facebook App ID
            },
            -- Whitelist Facebook apps
            LSApplicationQueriesSchemes =
            {
                "fb",  -- Needed for the facebook-v4a.isFacebookAppEnabled() API
                "fbapi",
                "fbauth2",
                "fb-messenger-api",
                "fbshareextension"
            },  


                    },
    },


	window = {
		titleText =
		{
			default = "X-ray",
		},
	},

	plugins = {
    ["plugin.facebook.v4a"] = {
      publisherId = "com.coronalabs"
      },
	  ["plugin.gameanalytics_v2"] = {
      publisherId = "com.gameanalytics",
      supportedPlatforms = { iphone=true, android=true }
      },
    ["plugin.bit"] = {
      publisherId = "com.coronalabs",
      supportedPlatforms = { iphone=true, android=true, osx=true, win32=true }
      },
    ["plugin.openssl"] = {
      publisherId = "com.coronalabs",
      },
  }, 
}



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,561 posts
  • Enterprise

We don't recommend including these lines:

            CFBundleIconFiles = {},  -- Required!  -- not required, you're using Images.xcassets
            CFBundleDisplayName = "Dragon Breaker",  -- let the Corona build dialog provide this
            CFBundleName = "Dragon Breaker", -- let the Corona build dialog provide this.

However, this looks like Game Analytics is including some unexpected files in their plugin. I've reached out to them.

 

Rob



[TOPIC: post.html]
#3

yofyibugne

[GLOBAL: userInfoPane.html]
yofyibugne
  • Observer

  • 2 posts
  • Corona SDK

Hi Rob, even am facing pretty simiar issue while trying to update my game/app on the store (free), Any way out?

 

Regards,

Smith 



[TOPIC: post.html]
#4

sdk21

[GLOBAL: userInfoPane.html]
sdk21
  • Observer

  • 2 posts
  • Corona SDK

Hi Rob,

 

We have received your request regarding this issue and I am trying to figure out what is going wrong. We are using the Project Template for building plugins. I can see from the error message that libplugin_gameanalytics_v2.a.orig is the problem but of course it should just be libplugin_gameanalytics_v2.a (and libGameAnalytics.a) which should be included in the plugin. I don't know how libplugin_gameanalytics_v2.a.orig has ended up in the plugin. I can see in our bitbucket repo (for corona) locally that the file libplugin_gameanalytics_v2.a.orig is here but from the history it doesn't seem to ever be commited to the server because *.orig files should be ignored according to the .hgignore file. Do you have any suggestions to what could be wrong or should I just try to submit a new version where I have deleted the *.orig from the repo?

 

Thanks,

Martin

Lead SDK Developer @ GameAnalytics



[TOPIC: post.html]
#5

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,561 posts
  • Enterprise

I'd remove the .orig files from the repo if you don't need them.

 

Rob



[TOPIC: post.html]
#6

sdk21

[GLOBAL: userInfoPane.html]
sdk21
  • Observer

  • 2 posts
  • Corona SDK

Ok I have removed the .orig files from the repo and released a new version of the plugin. Iofy let me know if you still have issues when submitting your app to the app store. Thanks, Martin


[topic_controls]
[/topic_controls]