Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Google error on API level
Started by uuela9971 Dec 23 2018 09:43 AM

2 replies to this topic
android api
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

uuela9971

[GLOBAL: userInfoPane.html]
uuela9971
  • Enthusiast

  • 65 posts
  • Corona SDK

I have just tried to release an updated version of my game to Google app store and am receiving the following error:

Your app currently targets API level 25 and must target at least API level 26 to ensure it is built on the latest APIs optimized for security and performance. Change your app's target API level to at least 26. Learn how.

 

The 'Learn how' doesn't really tell me mush as I am still new to setting up releases and so far have had no issues with production deployments until the Google API requirement change in October. This is my first attempt at a release since then. My API level is presently 25 according to Google.

 

What steps do I need to take to rectify this issue? I am using the most recent version of the API, am I missing a directive for the build file?



[TOPIC: post.html]
#2

uuela9971

[GLOBAL: userInfoPane.html]
uuela9971
  • Enthusiast

  • 65 posts
  • Corona SDK

additionally I am using build 3311 of Corona. It was my understanding that this build covered the API issue mentioned above.



[TOPIC: post.html]
#3

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,788 posts
  • Enterprise

2018.3326 is the first build to support API level 26 and above (API level 27). 3326 is also a public build. You need to get that or a later daily build!




[topic_controls]
[/topic_controls]