Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

11.4 (UNSUPPORTED: Local IOS SDK is 9.2 which does not match)
Started by jkappes01 Dec 20 2018 12:56 PM

3 replies to this topic
ios buildmac os xcode version help
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

jkappes01

[GLOBAL: userInfoPane.html]
jkappes01
  • Observer

  • 7 posts
  • Corona SDK

Dear anyone willing to help,

 

This is my first time with Corona and I am a new developer! I am at the end stages of my mobile app and I want to test it on my Iphone 6s.

 

My issue is that my Corona says my IOS SDK version is 9.2, which does not match. So I receive errors whenever I try to build for IOS.

 

Currently my Macbook Pro (Mid 2012) has MacOS High Sierra 10.13.4, I am running an xCode version (9.3) that I believe works with this version of MacOS. 

 

The solutions Corona provides to resolve the unsupported type is to xCode select xCode 9.3 or 9.4 to enable. However, this is confusing because my version of xCode is 9.3.

 

I recently just installed 9.3 because I had an outdated version of xCode for my MacOS current version. Maybe some temporary files of my old xCode are still in play... therefore making Corona think I still have an older version of xCode?

 

Any and all help is much appreciated!

 

Thankyou, Jason



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,154 posts
  • Corona SDK

What version of Corona are you using?

 

Rob



[TOPIC: post.html]
#3

jkappes01

[GLOBAL: userInfoPane.html]
jkappes01
  • Observer

  • 7 posts
  • Corona SDK

Hey Rob, I am using Version 2018.3326 (2018.6.25)



[TOPIC: post.html]
#4

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,154 posts
  • Corona SDK

To use 3326, you will need Xcode 9.4 since that version of Corona is based on iOS 11.4. Apple requires you to use a version of Xcode that matches (i.e. two major version numbers behind) the iOS SDK in use. Since Corona 2018.3326 is based on iOS 11.4, that means you have to use Xcode 9.4.

 

The latest daily build version of Corona (2018.3452) uses iOS 12.1 which means you need Xcode 10.1 to use it. If you find you can't run either of these Xcode versions on High Sierra, you might want to update to Mohave. 

 

Rob




[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: ios buildmac os, xcode version, help