Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Media.SelectVideo or CaptureVideo Unusable on IOS
Started by matt405 Dec 03 2018 05:44 AM

3 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

matt405

[GLOBAL: userInfoPane.html]
matt405
  • Contributor

  • 167 posts
  • Corona SDK

We have an app which we want to extend to support videos.

 

The Corona API has two video functions that we can use to either take a video or access videos: -

 

media.selectVideo

media.captureVideo

 

If I use either of these on IOS with say the following code: -

local testPlay = function(event)


     media.playVideo(event.url, media.RemoteSource ,true)
	
end

media.selectVideo  ( {listener = testPlay}  )

The resultant quality of the video is so bad it makes it unusable.  I have tested this on an IPHONE X and an IPAD Pro.

 

I hoped it was a old API issue so just updated the MAC to the latest build and the quality is the same.

 

It looks like the API call media.selectVideo works fine, but when the user select the video it completes an aggressive compression which is far worse than the compression used for saying emailing a video.

 

This works find on Android BTW.  This is just an IOS issue.

 

 



[TOPIC: post.html]
#2

XeduR @Spyric

[GLOBAL: userInfoPane.html]
XeduR @Spyric
  • Contributor

  • 368 posts
  • Corona SDK

If you use captureVideo, do you also include the optional preferredQuality string to ensure that the video is not captured at the default low quality?

Also, if the playVideo quality is bad, have you tried building Corona's sample project for both iOS and Android to ensure that it isn't just the capture quality that is bad?



[TOPIC: post.html]
#3

matt405

[GLOBAL: userInfoPane.html]
matt405
  • Contributor

  • 167 posts
  • Corona SDK

I have tried the CaptureVideo setting, however I suspect it will not make any difference.  It seems to be a compression that takes place after the video has been captured or selected and then returned to the App.  I guess this is the Corona API interface with IOS.

 

To ensure that it was not any of my code, I altered a Corona Sample project.   If you get time have a look at the below link.  You need to build it for an IOS device to test it.  Unfortunately, the output is the same - the video is really, really bad.

 

https://www.dropbox.com/s/vhspmmrac92l7ey/VideoPlayer.zip?dl=0

 

I have raised a bug report as I could do with this being fixed.  I will test the Capture Video with high quality and report back.



[TOPIC: post.html]
#4

matt405

[GLOBAL: userInfoPane.html]
matt405
  • Contributor

  • 167 posts
  • Corona SDK

OK, tried the media.captureVideo.  It is better if I select High as a quality setting.  I would say it is almost usable if they capture a video live.

 

I hoped that they may have not documented that setting in media.selectVideo and I tried it with that setting, but no, that did not work.

 

The problem I have is that 9 times out of 10 they will be loading a video previously recorded.  That quality is truly terrible.  I videoed some text on paper via the IPAD.  Selected it and played it and the test was just a blurry mess.

 

I submitted a bug report, but ever got anything back.  I may try and submit it again.  Really need this fixed.




[topic_controls]
[/topic_controls]