Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Admob new plugin
Started by tsoakuo Dec 01 2018 08:30 AM

3 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

tsoakuo

[GLOBAL: userInfoPane.html]
tsoakuo
  • Observer

  • 3 posts
  • Corona SDK

I have a problem with the new admob plugin of corona-sdk platform.
 
In one hand, I have an app that I already published to Google Play long time ago and yesterday I purchashed the new admob plugin, so I rebuild the app and add an ad banner using the new admob plugin - It worked propely.
 
On the other hand, I have an app that I did not published yet (brand new), I tried to add a banner using the new admob plugin (the SAME way I did with the other app - same code same everything - also the build.setting).
I can see an ad only if it's using TestMode=true.
 
This is how I did it:
I have the main.lua init the ad:
 
    
local function adListener( event )
    if ( event.phase == "init" ) then
        admob.load( "banner", { adUnitId="ca-app-pub-xxxxx/xxxxx" } )
    end
end
     
admob.init( adListener, { appId="ca-app-pub-xxxxxx~xxxxxxx"} )
 
 
and in an scene I do this:
 
    
if ( admob.isLoaded( "banner" ) ) then
    bannerHeight = admob.height()
    admob.show( "banner", { y = display.actualContentHeight - bannerHeight} )
end
 
I tried everything, I know the ad unit works because I check it on the first app that the banner works there.
My only thought left is that maybe it's happenning becuase I didn't published the app yet..
 
Hope for help, Thank you all.


[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,000 posts
  • Corona SDK

Please review this tutorial:  http://docs.coronalabs.com/tutorial/basics/ads/index.html

 

In particular pay close attention to the section where it talks about debugging your ad installation by putting print statements in your adListener function. You cannot possibly debug the problem without knowing what messages AdMob is returning to you.

 

Rob



[TOPIC: post.html]
#3

tsoakuo

[GLOBAL: userInfoPane.html]
tsoakuo
  • Observer

  • 3 posts
  • Corona SDK

Please review this tutorial:  http://docs.coronalabs.com/tutorial/basics/ads/index.html

 

In particular pay close attention to the section where it talks about debugging your ad installation by putting print statements in your adListener function. You cannot possibly debug the problem without knowing what messages AdMob is returning to you.

 

Rob

I used event.response to see the response from admob:
I got "loadFaild" with error code 3 that says no ads aviable..
I created a timer that try very 4 seconds to init it again and its always return a response of "loadFaild".. nothing more



[TOPIC: post.html]
#4

gamebit.labs

[GLOBAL: userInfoPane.html]
gamebit.labs
  • Contributor

  • 164 posts
  • Corona SDK

Beginning the end of November, I experienced irregular drop in earning and ecpm from Admob. If you visit the Admob Forum, you'll notice huge amounts of complaints of apps not getting ads and the infamous "error code 3"

 

No idea yet what is really happening. Can Corona keep an eye on this issue and review if there is a need to update the plugin?

 

Ben




[topic_controls]
[/topic_controls]