Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Missing files from Corona Native iOS build
Started by Studycat2 Nov 22 2018 07:12 PM

1 reply to this topic
native ios build error
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

Studycat2

[GLOBAL: userInfoPane.html]
Studycat2
  • Enthusiast

  • 70 posts
  • Corona SDK

I've encountered an error when I try to build for iOS using Corona Native. Android native builds work fine from Android Studio. The problem is that when I try to "Run" or build the project to a device using xCode, it tells me it is missing two files:

CpResource /Applications/Corona/Native/Project\ Template/App/ios/~/Library/Application\ Support/Corona/Native/Corona/shared/resource/Corona3rdPartyLicenses.txt /Users/chomsky/Library/Developer/Xcode/DerivedData/App-gergpzhpjbzfmugjpxuvgqwfclps/Build/Products/Debug-iphonesimulator/App.app/Corona3rdPartyLicenses.txt (in target: App)
    cd /Applications/Corona/Native/Project\ Template/App/ios
    builtin-copy -exclude .DS_Store -exclude CVS -exclude .svn -exclude .git -exclude .hg -resolve-src-symlinks /Applications/Corona/Native/Project\ Template/App/ios/~/Library/Application\ Support/Corona/Native/Corona/shared/resource/Corona3rdPartyLicenses.txt /Users/chomsky/Library/Developer/Xcode/DerivedData/App-gergpzhpjbzfmugjpxuvgqwfclps/Build/Products/Debug-iphonesimulator/App.app

error: /Applications/Corona/Native/Project Template/App/ios/~/Library/Application Support/Corona/Native/Corona/shared/resource/Corona3rdPartyLicenses.txt: No such file or directory

and 

CpResource /Applications/Corona/Native/Project\ Template/App/ios/~/Library/Application\ Support/Corona/Native/Corona/ios/resource/CoronaResources.bundle /Users/chomsky/Library/Developer/Xcode/DerivedData/App-gergpzhpjbzfmugjpxuvgqwfclps/Build/Products/Debug-iphonesimulator/App.app/CoronaResources.bundle (in target: App)
    cd /Applications/Corona/Native/Project\ Template/App/ios
    builtin-copy -exclude .DS_Store -exclude CVS -exclude .svn -exclude .git -exclude .hg -resolve-src-symlinks /Applications/Corona/Native/Project\ Template/App/ios/~/Library/Application\ Support/Corona/Native/Corona/ios/resource/CoronaResources.bundle /Users/chomsky/Library/Developer/Xcode/DerivedData/App-gergpzhpjbzfmugjpxuvgqwfclps/Build/Products/Debug-iphonesimulator/App.app

error: /Applications/Corona/Native/Project Template/App/ios/~/Library/Application Support/Corona/Native/Corona/ios/resource/CoronaResources.bundle: No such file or directory

I have looked to check in ~/Library/Application Support/Corona/Native/Corona/ios/resource/, and I see that these files exist, so I don't understand what the problem is, or if there is something funky with my setup. For example, in the terminal I can see:
 

my-MacBook-Pro:Library chomsky$ cd ~/Library/Application\ Support/Corona/Native/Corona/shared/resource/
my-MacBook-Pro:resource chomsky$ ll
total 128
-rw-r--r--@ 1 chomsky  admin    72K Jun 26 02:38 Corona3rdPartyLicenses.txt
-rw-r--r--@ 1 chomsky  admin    23K Jun 26 02:38 CoronaPListSupport.lua
lrwxr-xr-x  1 chomsky  admin    26B Jun 26 03:39 CoronaSDK3rdPartyLicenses.txt -> Corona3rdPartyLicenses.txt
-rw-r--r--@ 1 chomsky  admin   518B Jun 26 02:38 developerkey.cert
-rw-r--r--@ 1 chomsky  admin    22K Jun 26 02:38 dkjson.lua
-rw-r--r--@ 1 chomsky  admin   2.7K Jun 26 02:38 json.lua
and
 
my-MacBook-Pro:resource chomsky$ ll
total 28
drwxr-xr-x@ 19 chomsky  admin   608B Jun 26 03:00 CoronaResources.bundle/
-rw-r--r--@  1 chomsky  admin   1.8K Jun 26 03:00 MainWindow-iPad.xib
-rw-r--r--@  1 chomsky  admin   1.9K Jun 26 03:00 MainWindow.xib
-rw-r--r--@  1 chomsky  admin    20K Jun 26 03:00 _CoronaSplashScreen.png
my-MacBook-Pro:resource chomsky$ pwd
/Users/chomsky/Library/Application Support/Corona/Native/Corona/ios/resource
my-MacBook-Pro:resource chomsky$
 

The plugin scheme runs and succeeds, if I switch to it and run that.

 

I have tried uninstalling Corona and deleting the ~/Library/Application Support/Corona folder, and then reinstalling and setting up Corona native again, but I get the same error, in my project and in the project template folder that comes with Corona native. I'm running xCode 10.1 (10B61). My corona version is 2018.3326. My OSX version is 10.14.1, if that makes any difference.

 

What can I do to get past these errors?



[TOPIC: post.html]
#2

mpayne002

[GLOBAL: userInfoPane.html]
mpayne002
  • Observer

  • 22 posts
  • Corona SDK

I think the problem is because the path is prefixed with:

/Applications/Corona/Native/Project\ Template/App/ios/~
/Applications/Corona/Native/Project\ Template/App/ios/~/Library/Application\ Support/Corona/Native/Corona/shared/resource/Corona3rdPartyLicenses.txt

I had the same issue. When I ran "Setup Corona Native" it created a symlink at :

/Users/m/Library/Application Support/Corona/Native

But Xcode is looking at:

/Library/Application Support/Corona/Native

So I created the symlink myself:

sudo mkdir /Library/Application\ Support/Corona

sudo ln -s /Applications/Corona/Native/ /Library/Application\ Support/Corona/Native

Then modified the file

 

CoronaNative.xcconfig (in Xcode, Show Project Navigation -> App -> CoronaNative -> CoronaNative.xcconfig

 

And deleted $HOME from CORONA_ROOT.

 

Then you must close Xcode, re-open and Clean.

 

Now that got rid of the error, but I'm getting 'No definition found' when I run the Xcode simulator, so I don't know if that's a fix, but hopefully it helps a bit.

 

EDIT

 

Makes sense that it's showing that popup with 'no definition found', considering that's the code inside main.lua. :)

 

Mike




[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: native, ios, build, error