Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

ERROR : Invalid Facebook App ID
Started by umalemon Sep 16 2018 10:05 PM

30 replies to this topic
[TOPIC CONTROLS]
Page 2 of 2 1 2
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#26

umalemon

[GLOBAL: userInfoPane.html]
umalemon
  • Enthusiast

  • 97 posts
  • Corona SDK

I think that there are probably several build servers, and some of them have problems.
 
A few months ago, due to this problem I made the number of uninstalls of my application severely large.
We also received reports that advertisements of Appodeal are often not played properly.
The recent instability of Corona greatly impairs the profitability of my application.
 
I have also paid for the Corona Splash Screen plugin.
I am also paying a few percent of Advertising revenue for Appodeal.
 
I hope.
Corona should prepare a document on how to build an easy-to-follow build server, or want to resolve this problem as soon as possible.
 
The problem of each plug-in is also so, but the final build problem is fatal.


[TOPIC: post.html]
#27

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,377 posts
  • Enterprise

We have multiple build servers, so the first thing we thought is that one server was different than another, but we have confirmed that a build ID that failed on server X also built successfully for the same user on the same server X. This has us scratching our head and we continue to research the issue. Perhaps at some point, there will be an "Ah ha!" moment and we can solve this.

 

I want this problem solved as much as you do, but given our difficulty finding this, I'm simply presenting you an alternative and very functional way for this to not be a problem for you. And frankly, since it seems this is only happening on Android builds and not iOS builds, you would only need to do native builds on Android and still use the simulator for iOS builds.

 

Corona developer @agramonte put together a very nice video explaining how to build your Corona app using Android Studio: https://forums.coronalabs.com/topic/74578-integrate-android-studio-whith-corona-sdk/

Rob 



[TOPIC: post.html]
#28

dooq

[GLOBAL: userInfoPane.html]
dooq
  • Enthusiast

  • 39 posts
  • Corona SDK

This build bug is still happening with Corona Version 2019.3467 (2019.2.26)

 

:(  :angry:  :wacko:



[TOPIC: post.html]
#29

dooq

[GLOBAL: userInfoPane.html]
dooq
  • Enthusiast

  • 39 posts
  • Corona SDK

Perhaps changing the error dialog to something better (that didn't fully stop the app from functioning) would be an interim step, if you can't find the cause of the problem



[TOPIC: post.html]
#30

dooq

[GLOBAL: userInfoPane.html]
dooq
  • Enthusiast

  • 39 posts
  • Corona SDK

To repeat what somebody mentioned earlier: I also notice that the message of the popup mentions an ID number which is the good one except that the last character is replaced by a "!"

 

Does this dialog list the FB app ID it's trying to use? If so, the last character is getting replaced by a "!". perhaps this is a useful clue to help your bug hunters



[TOPIC: post.html]
#31

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,377 posts
  • Enterprise

I would suggest trying a native build. @agramonte did a great video series for helping people create Android builds using Corona Native:

 

https://forums.coronalabs.com/topic/74578-integrate-android-studio-whith-corona-sdk/

 

 

Rob




[topic_controls]
Page 2 of 2 1 2
 
[/topic_controls]