Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Problem with OpenSSL
Started by maxim.palitaev Aug 31 2018 07:55 AM

5 replies to this topic
openssl
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

maxim.palitaev

[GLOBAL: userInfoPane.html]
maxim.palitaev
  • Observer

  • 3 posts
  • Corona SDK

Hello! It's my first question in this forum. Sorry for my bad english.

I need help. I have got problem. I write system of saving\loading, but got error in game, when i want load my savedata.

 

It's my code:

 

https://pastebin.com/VrMp7kFG

 

ERROR log is:

 

stack traceback:
[C]: in function 'pairs'
C:\Users\Admin\Desktop\G.E.T.T.E.R\scripts\menu.lua:70: in function '_onEvent'
?: in function '?'
?: in function '?'
?: in function <?:190>

 

 


  • maxim.palitaev likes this

[TOPIC: post.html]
#2

XeduR @Spyric

[GLOBAL: userInfoPane.html]
XeduR @Spyric
  • Contributor

  • 291 posts
  • Corona SDK

Could you reformat your post using the < > code tag? That way your code will be readable and we can try to help you out.


  • agramonte and maxim.palitaev like this

[TOPIC: post.html]
#3

maxim.palitaev

[GLOBAL: userInfoPane.html]
maxim.palitaev
  • Observer

  • 3 posts
  • Corona SDK

Sorry, i did it.



[TOPIC: post.html]
#4

XeduR @Spyric

[GLOBAL: userInfoPane.html]
XeduR @Spyric
  • Contributor

  • 291 posts
  • Corona SDK

Your inventory and g_time tables are properly formatted, but the rest of it is still a mess. You should also include the accurate line numbers so that we can more easily see which line results in the error, i.e. what's on line #70?

The easier you make it for others to read your code and replicate your error, the more likely you are to get an answer. 



[TOPIC: post.html]
#5

maxim.palitaev

[GLOBAL: userInfoPane.html]
maxim.palitaev
  • Observer

  • 3 posts
  • Corona SDK

Hmm. It's strange. I'm always broke here formatting.
I just deleted the code and uploaded it to pastebin.com
I really hope for your help. Thank you for your patience.


[TOPIC: post.html]
#6

XeduR @Spyric

[GLOBAL: userInfoPane.html]
XeduR @Spyric
  • Contributor

  • 291 posts
  • Corona SDK

I had a quick look at your code, but there isn't enough for me to replicate the problem, nor do I know on which line or how you encounter the problem. I would have to parse your code word by word, looking for any kind of typo or mistake, and that would take far longer than I am comfortable with.

I would recommend having a look at https://github.com/coronalabs/plugins-sample-openssl. See first if your encryption and decryption work properly, then look into your loading and saving functions.




[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: openssl