Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Build Failed Error Code 256
Started by d2gp Aug 24 2018 07:58 AM

1 reply to this topic

Best Answer d2gp , 24 August 2018 - 08:10 AM

Never mind, I resolved it. One of the new Android app icons had a typo in the name. 

[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

d2gp

[GLOBAL: userInfoPane.html]
d2gp
  • Contributor

  • 228 posts
  • Corona SDK

hi

 

a week ago I put an app on the Android store, and quickly added a few releases. 

 

Yesterday I tried to put another new release up but am getting "Build Failed Error Code 256" every time I try. 

 

There's a few things that changed between the last successful build and the failing attempts:

 

1. I removed the Images.xcassets folder as it's iOS-specific and added 6 Android icons

2. I rearranged the structure of my app project folders, including for this app

3. I erroneously renamed the app's project folder (the one containing main.lua) and may have tried a build using that, but I think the name is back to what it was before.

 

I was using the latest public build when I got the first failed build last night, so I downloaded the 2018.3356 daily build but that failed too. I'm on a Mac (high sierra)

 

Here's some console output:

 

Aug 24 08:40:49.663 Picked up JAVA_TOOL_OPTIONS: -Duser.language=en

Aug 24 08:41:37.551 Using java version "1.6.0_65"
                Java™ SE Runtime Environment (build 1.6.0_65-b14-468)
                    Java HotSpot™ 64-Bit Server VM (build 20.65-b04-468, mixed mode)
Aug 24 08:41:38.307 Building Android app for XXXXXX with 2018.3356
Aug 24 08:41:40.330 Using custom build id from app bundle: 00000 (AppSettings.lua)
Aug 24 08:41:41.514 BUILD SUCCESSFUL
                    Total time: 0 seconds
Aug 24 08:42:33.652 BuildID: 5b80273757226
Aug 24 08:42:53.578 BUILD FAILED
                    /Applications/Corona-3356/Corona Simulator.app/Contents/Resources/build.xml:501: The following error occurred while executing this line:
                    /Applications/Corona-3356/Corona Simulator.app/Contents/Resources/build.xml:391: The following error occurred while executing this line:
                    /Applications/Corona-3356/Corona Simulator.app/Contents/Resources/build.xml:313: The following error occurred while executing this line:
                    /Applications/Corona-3356/Corona Simulator.app/Contents/Resources/build.xml:252: The following error occurred while executing this line:
                    /Applications/Corona-3356/Corona Simulator.app/Contents/Resources/build.xml:218: Missing required file: Icon-hdpi-v4.png
                    
                    Total time: 2 seconds
Aug 24 08:42:53.578 
Aug 24 08:42:53.668 Android build failed (256) after 73 seconds
Aug 24 08:42:54.036 ERROR: Build Failed: Error code: 256

 



[TOPIC: post.html]
#2

d2gp

[GLOBAL: userInfoPane.html]
d2gp
  • Contributor

  • 228 posts
  • Corona SDK

  Best Answer

Never mind, I resolved it. One of the new Android app icons had a typo in the name. 




[topic_controls]
[/topic_controls]