Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Error to load App trought Application Loader
Started by gturmo Aug 08 2018 09:38 AM

3 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

gturmo

[GLOBAL: userInfoPane.html]
gturmo
  • Observer

  • 22 posts
  • Corona SDK

Hello,

 

I'm trying to upload an iOS app trought Application Loader but when I doing it it shows the following message errors:

 

ERROR ITMS-90023: "Missing required icon file. The bundle does not contain an app icon for iPad of exactly '72x72' pixels, in .png format for iOS versions < 7.0."

 

 

I followed this documentation and it doesn't said that I need to create these 72x72px icon. What I amd doing wrong?

 

ERROR ITMS-90023: "Missing required icon file. The bundle does not contain an app icon for iPad of exactly '167x167' pixels, in .png format for iOS versions supporting iPad Pro."
 

 

 

I followed this documentation and it doesn't said that I need to create these 72x72px icon. What I amd doing wrong?

 
 
 
ERROR ITMS-90725: "SDK Version Issue. This app was built with the iOS '9.2' SDK. All iOS apps submitted to the App Store must be built with the iOS '11.0' SDK or later, included in Xcode [9.0] or later. Please update Xcode and rebuild your app."

 

 

I don't understand it because I'm using Corona 2018.3326 version and on my Mac I have installed xcode 9.4.1

 

When I'm building .ipa file it shows this advisor:

The version of iOS SDK (11.4) that's installed on this computer does not match the target iOS version (9.2). You may encounter issues building or incompatibilities at runtime.

You should consider updating your version of Xcode or using xcode-select to enable a compatible version.

Do you want to proceed with a build?

I don't understand it because I'm using Corona 2018.3326 version and on my Mac I have installed xcode 9.4.1 that it must to have iOS SDK 11.4

 

 

Thanks for your support.



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 24,743 posts
  • Corona Staff

Can you post your build.settings file, please?

 

Rob



[TOPIC: post.html]
#3

gturmo

[GLOBAL: userInfoPane.html]
gturmo
  • Observer

  • 22 posts
  • Corona SDK

Yes, of course.

 

--
-- For more information on build.settings, see the Project Build Settings guide at:
-- https://docs.coronalabs.com/guide/distribution/buildSettings
--


settings =
{
-- Eliminar SplahScreen
    splashScreen =
    {
        ios = {
            enable = false
        },
        android = {
            enable = false
        }
    },


orientation =
{
-- Supported values for orientation:
-- portrait, portraitUpsideDown, landscapeLeft, landscapeRight
default = "portrait",
supported = { "portrait", },
},


--
-- Android section
--
android =
{
usesPermissions =
{
"android.permission.INTERNET",
},
},


--
-- iOS section
--
iphone =
{
xcassets = "Images.xcassets",
plist =
{
UIStatusBarHidden = false,
UILaunchStoryboardName = "LaunchScreen",
},
},


--
-- Plugins section
--
plugins =
{


},


--
-- Project section
--
excludeFiles =
{
-- Exclude unnecessary files for each platform
android = { "LaunchScreen.storyboardc", },
},
}

Also, when I'm in Build for iOS view on Corona's SDK, I can't change iOS SDK to 11.4 (Lastest version and only that is allowed to upload on AppStore). I have installed in my computer Xcode 9.4.1. I attached a screencapture with it.

 
Thanks for your support.

Attached Files



[TOPIC: post.html]
#4

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 24,743 posts
  • Corona Staff

Can you provide a screenshot of the welcome window or the dialog that pops up when you click on the "Corona Simulator->About Corona Simulator" link.

 

Also can you open the Terminal app and run this command:

 

 xcode-select -p

 

and paste the results back here?

 

3326 uses iOS 11.4 and doesn't have an option for 9.2.

 

Rob




[topic_controls]
[/topic_controls]