Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

I have a trouble with the "magTextureFilter" in using "nearest" option
Started by kooostia16 Jul 18 2018 05:23 AM

3 replies to this topic
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

kooostia16

[GLOBAL: userInfoPane.html]
kooostia16
  • Observer

  • 5 posts
  • Corona SDK

When i'm launching the game on android, i have those artifacts on each sprite-object, but on windows it seems pretty well without artifacts

 

 

 

 

Spoiler



[TOPIC: post.html]
#2

ldurniat

[GLOBAL: userInfoPane.html]
ldurniat
  • Contributor

  • 388 posts
  • Corona SDK

Hi kooostia16,

 

Try Moving objects with magTextureFilter set to nearest problem

 

@d.mach: You can load images while using "nearest". When images are loaded and scaled you can switch back to "linear" and transitions will be smooth.

 

Have a nice day:)

 

ldurniat



[TOPIC: post.html]
#3

kooostia16

[GLOBAL: userInfoPane.html]
kooostia16
  • Observer

  • 5 posts
  • Corona SDK

Hi kooostia16,

 

Try Moving objects with magTextureFilter set to nearest problem

 

 

Have a nice day:)

 

ldurniat

hmm. It doesn't work, but thanks anyway.



[TOPIC: post.html]
#4

kooostia16

[GLOBAL: userInfoPane.html]
kooostia16
  • Observer

  • 5 posts
  • Corona SDK

I solved it. So i used more bigger sprites and setted "isImageSheetSampledInsideFrame" to true




[topic_controls]
[/topic_controls]