Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Unable to download any plugins.
Started by agramonte Jul 02 2018 02:02 PM

14 replies to this topic
download plugins
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Contributor

  • 859 posts
  • Corona SDK

Has anybody seen this error before? The same error for Android and iOS download script:

 

 

PANIC: unprotected error in call to Lua API (?:0: attempt to concatenate field 'plugin_developer' (a nil value))

PANIC: fatal Lua error: ?:0: attempt to concatenate field 'plugin_developer' (a nil value)

 



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,000 posts
  • Corona SDK

What version of Corona are you using?  I just did a test on iOS and the Xcode Download Plugin schema ran with no errors. What plugins do you have in your build.settings?

 

Rob



[TOPIC: post.html]
#3

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Contributor

  • 859 posts
  • Corona SDK

Rob, I tried with the following version of Corona: current public, 3297, 3301, 3301, 3316. I reset the native path with each version. I tried it with two old projects I had not built in a while. I also tried my project with only 1 plugin in the build settings:

["plugin.openssl"] =
        {
            publisherId = "com.coronalabs",
        },

No worries. Since you confirmed it works on your end, I'll figure it out. My next step is to try with a clean new project. I'll write back once I figure it out.



[TOPIC: post.html]
#4

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Contributor

  • 859 posts
  • Corona SDK

I tried with a brand new project and the same issue. It must be something about the path or permission somewhere on my machine. In any case, I only do native builds to add one library (tappx) and it is not that important if my corona apps don't have it in the next build.



[TOPIC: post.html]
#5

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Contributor

  • 859 posts
  • Corona SDK

Rob some more updates. I don't know if I need to open up a ticket, but here is what I did:

 

1. If I use my current account I always get the error mentioned above.

2. If I switch to my second account (which I currently don't use since the limit of 2 machines doesn't exist anymore), I am able to pull the plugins without any issues. 

 

The error occurs with my regular account on 2 completely machines.

The error does not occur on my regular machine with the other account.



[TOPIC: post.html]
#6

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,000 posts
  • Corona SDK

Have you tried deauthorizing and quitting and then logging back in?

 

Rob



[TOPIC: post.html]
#7

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Contributor

  • 859 posts
  • Corona SDK

 

 

Have you tried deauthorizing and quitting and then logging back in?

Yes, sir.



[TOPIC: post.html]
#8

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,000 posts
  • Corona SDK

I've asked Engineering I just don't have an answer yet.

 

Rob


  • agramonte likes this

[TOPIC: post.html]
#9

roballison182

[GLOBAL: userInfoPane.html]
roballison182
  • Contributor

  • 181 posts
  • Corona SDK

Hey, not sure if this is related but;

 

I cleared my plugins directory (in native; Xcode) and then tried to redownload plugins. It doesn't fail (that I can see) but then when I try build the actual app it fails due to missing plugins.



[TOPIC: post.html]
#10

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Contributor

  • 859 posts
  • Corona SDK

@roballison. I believe that is a different issue and I also experienced it with my working id.

 

To fix that I:

1. Checked that the plugins have been downloaded.

2. If they are available I added them to the framework search path of the project.

 

Hope that helps our issue.



[TOPIC: post.html]
#11

Bektur

[GLOBAL: userInfoPane.html]
Bektur
  • Contributor

  • 150 posts
  • Corona Staff

@agramonte I've cleaned your previous authorizations. Can you please log in and try again?



[TOPIC: post.html]
#12

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Contributor

  • 859 posts
  • Corona SDK

@bektur Thank you for trying. Still the same issue. 

 

1. Closed xcode.

2. Logout and closed corona.

3. Logged back in with my usual id. (mXXXX@adriangomez.com)

4. Tried to download plugins. Same error.

5. Logged and closed corona.

6. Logged back in with my working id. (adrixxxxx@gmail.com)

7. Did not close xcode and tried to download plugins and it worked.



[TOPIC: post.html]
#13

billyfairbank

[GLOBAL: userInfoPane.html]
billyfairbank
  • Observer

  • 25 posts
  • Corona SDK

I am getting that same error here trying to download Android plugins.

 

Already tried de-authorizing and authorizing back in and also downloaded the latest Corona Native (3447)

 

My build.settings is:

settings =
{	plugins =
    {
        ["plugin.OneSignal"] =
       {
           publisherId = "com.onesignal",
       },
    },
	iphone =
	{
		xcassets = "Images.xcassets",
		plist =
		{
			UILaunchStoryboardName = "LaunchScreen",
		},
	},
}

when I try to run:

./download_plugins.sh 

I get the error:

PANIC: unprotected error in call to Lua API (?:0: attempt to concatenate field 'plugin_developer' (a nil value))
PANIC: fatal Lua error: ?:0: attempt to concatenate field 'plugin_developer' (a nil value)


[TOPIC: post.html]
#14

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Contributor

  • 859 posts
  • Corona SDK

I created a second account to download the plugins. I was never able to resolve this issue on my primary account. If for whatever reason you get yours fixed please let me know the solution. I am fairly sure this happens when a plugin you paid for expires without being renewed.



[TOPIC: post.html]
#15

billyfairbank

[GLOBAL: userInfoPane.html]
billyfairbank
  • Observer

  • 25 posts
  • Corona SDK

@agramonte, I think you indeed found something. Tried using a different Corona account and it worked. 




[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: download, plugins