Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Incorrect splash screen
Started by sara.r Jun 24 2018 03:22 AM

6 replies to this topic
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

sara.r

[GLOBAL: userInfoPane.html]
sara.r
  • Observer

  • 6 posts
  • Corona SDK

I had Corona Enterprise edition and use custom splash screen. I used to build native and so go on till now without any problem. Now when I Run on device I'm suddenly getting

"Application Validation Error:

 

Incorrect splash screen - the splash screen built into the app is not the one that shipped with build 2017.3184 of Corona.

Activate the Corona Splash Screen Control plugin in the Marketplace if you want to customize it."

 

I tried to disable custom splash and using default Corona splash by removing  _CoronaSplashScreen.png from root (for iOS) and "res/drawable" folder(for Android) of my project. But I got the same error again.

 
1 - What should I do  to build my app with default splash screen in Corona Native?
2 - How can I resolve this error for using custom splash screen again?


[TOPIC: post.html]
#2

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Contributor

  • 675 posts
  • Corona SDK

Copy the most recent splash screen image from the template folder to your old project. This usually does the trick for me when I get this error.



[TOPIC: post.html]
#3

sara.r

[GLOBAL: userInfoPane.html]
sara.r
  • Observer

  • 6 posts
  • Corona SDK

It doesn't work!

Thank you for answering.



[TOPIC: post.html]
#4

alireza.poorsohoolat

[GLOBAL: userInfoPane.html]
alireza.poorsohoolat
  • Observer

  • 21 posts
  • Corona SDK

I have same issue. any solution?



[TOPIC: post.html]
#5

karpovpw

[GLOBAL: userInfoPane.html]
karpovpw
  • Contributor

  • 229 posts
  • Corona Staff

Hey guys!

When you are building apps with Corona Native, you should always use splash screen from the templates of Corona Simulator you've got at the moment, basically.

It's strange that it doesn't help you, we are looking at what may be causing the issue at the moment.



[TOPIC: post.html]
#6

TandG

[GLOBAL: userInfoPane.html]
TandG
  • Contributor

  • 420 posts
  • Corona SDK

Have you guys definitely got an active subscription to the Splash Screen Control plugin?

 

Mine expired yesterday, I imagine it's been a year since Corona enterprise was made free and enterprise users given this plugin for a year. I simply bought it again, cleaned my Xcode project and it started working fine again.



[TOPIC: post.html]
#7

sara.r

[GLOBAL: userInfoPane.html]
sara.r
  • Observer

  • 6 posts
  • Corona SDK

I did a mistake before. I taken the file from  "/Applications/Corona/Native/Project Template/App/ios" and rename and put it on android folder too. It seems my problem with @Agramonte solution was this. 




[topic_controls]
[/topic_controls]