Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

ERROR ITMS-90709 on submission
Started by Studycat2 May 18 2018 12:06 AM

4 replies to this topic
tvos apple icon build.settings
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

Studycat2

[GLOBAL: userInfoPane.html]
Studycat2
  • Enthusiast

  • 72 posts
  • Corona SDK

Hi! I've been attempting to submit an update to an Apple tvOS app, and am getting the following error when uploading with application loader:

 

ERROR ITMS-90709: "Invalid Image Asset. The image asset 'App Icon - Small' in 'Payload/build-apple-xxx.app' is missing an image for the background layer with a scale value of '2'."

 

I've also tried with the Corona Cannon sample app, (https://github.com/coronalabs-samples/CoronaCannon), which is said to be tvOS ready, and attempted to upload it with those assets, but got the same error. I only modified this project's build.settings slightly to attempt to upload. I've attached my changed build.settings file (I've changed my app id to xxx.xxx.xxx).  Keep in mind that the name of the file is different, to allow me to attach it here.

 

Am I missing something? What do I need to do differently to avoid getting this error? My app runs fine when I build it with a development profile, and put it on my Apple TV with a cable. Do I need to use an xcassets folder with tvOS builds? Or not?

Attached Files



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,801 posts
  • Enterprise

Looks like Apple has changed the requirements.  See:  https://developer.apple.com/tvos/human-interface-guidelines/icons-and-images/app-icon/

 

I would start with just providing @2x versions. In other words provide:

 

Icon-tvOS-Small-1.png (400px x 240px)  and

Icon-tvOS-Small-1@2x.png (800px × 480px)

 

and see if that solves it.

 

Rob



[TOPIC: post.html]
#3

Studycat2

[GLOBAL: userInfoPane.html]
Studycat2
  • Enthusiast

  • 72 posts
  • Corona SDK

Hi there, Rob!

 

Thanks for the suggestion, but I don't think it was the problem. I've added @2x versions of all my icon files with the correct dimensions -- see attached screenshots -- and I'm still getting the same error on submission. Screenshots of new images in folder:

 

https://imgur.com/a/eQm7Xxe

 

Any idea what else it could be? I've checked the color spaces and the transparency for these images, but all looks to be in order. Any chance you've got a working, building tvOS project with images around that I could check out?

 

S



[TOPIC: post.html]
#4

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 727 posts
  • Corona Staff

Hello! Thanks for pointing that out. It seems that Apple started to require 4k assets in their builds. Here is icons I was able to submit without any warnings: https://www.dropbox.com/s/2v4hdl450fdsqfa/Images.xcassets.zip?dl=0

As aways, you can drag&drop Images.xcassets in your project on Xcode to see images, icons and warnins about them. I also noticed that tvOS guide is very outdated.

If you confused what to do with Images.xcassets, check out ShapeTumbler sample from Physics directory. I was able to submit it with attached icons. It would be updated in next daily build.



[TOPIC: post.html]
#5

Studycat2

[GLOBAL: userInfoPane.html]
Studycat2
  • Enthusiast

  • 72 posts
  • Corona SDK

Thanks for the point in the right direction, vlads! This worked. 




[topic_controls]
[/topic_controls]