Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

EmitterObject — Blend Modes question
Started by Sig.g1 May 14 2018 07:20 AM

3 replies to this topic
particles

Best Answer Sig.g1 , 14 May 2018 - 02:26 PM

Combination found!

 

https://forums.coronalabs.com/topic/66241-trouble-with-displaynewemitter/

 

blendFuncSource:1

blendFuncDestination:771

[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

Sig.g1

[GLOBAL: userInfoPane.html]
Sig.g1
  • Enthusiast

  • 98 posts
  • Corona SDK

I've been using the particles for a short time. They are really great!

 

Everything works fine as long as I use a dark background but if the background is different the particles blend with it and they become not very visible and ugly.

 

How do I avoid this?

I like the particles to blend together. But I want them not to blend with the background or anyway with all that is there.

 

how can this be done?



[TOPIC: post.html]
#2

SGS

[GLOBAL: userInfoPane.html]
SGS
  • Corona Geek

  • 1,840 posts
  • Corona SDK

Try experimenting with these values - https://docs.coronalabs.com/api/type/EmitterObject/index.html#particles-blend-modes



[TOPIC: post.html]
#3

Sig.g1

[GLOBAL: userInfoPane.html]
Sig.g1
  • Enthusiast

  • 98 posts
  • Corona SDK

I've already tried. otherwise I would not have asked ...



[TOPIC: post.html]
#4

Sig.g1

[GLOBAL: userInfoPane.html]
Sig.g1
  • Enthusiast

  • 98 posts
  • Corona SDK

  Best Answer

Combination found!

 

https://forums.coronalabs.com/topic/66241-trouble-with-displaynewemitter/

 

blendFuncSource:1

blendFuncDestination:771




[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: particles