Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Security and performance issues on play store.
Started by usmanmughal.uog May 14 2018 02:49 AM

6 replies to this topic
security performance playstore warnings api support api level 26
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

usmanmughal.uog

[GLOBAL: userInfoPane.html]
usmanmughal.uog
  • Enthusiast

  • 52 posts
  • Corona SDK

Warnings 

 

Your app currently targets API level 25 and must target at least API level 26 to ensure it is built on the latest APIs optimized for security and performance.

From August 2018, new apps must target at least Android 8.0 (API level 26).
From November 2018, app updates must target Android 8.0 (API level 26).

Tip: Change your app's target API level. Learn how.



I tried to build APK with latest Corona build but still I get this error when I upload APK to play store. Is there something I can do to avoid this warning.

Regards,
Usman Mughal

 



[TOPIC: post.html]
#2

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Contributor

  • 681 posts
  • Corona SDK

I believe this will have to wait until Corona changes the targeted SDK. Don't stress we have plenty of time.



[TOPIC: post.html]
#3

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 24,315 posts
  • Corona Staff

It's not an error and you can ignore it for now. As @agramonte said, this will have to wait until we update Corona to use API level 26. This is not something that's just a switch flip or a simple Corona rebuild using that API level. It's a big task for us to do this. We know we have to do it and will soon, but we have many other really high priority issues to deal with right now.

 

Rob


  • elifares likes this

[TOPIC: post.html]
#4

usmanmughal.uog

[GLOBAL: userInfoPane.html]
usmanmughal.uog
  • Enthusiast

  • 52 posts
  • Corona SDK

Thanks for update Rob. Google was complaining some other errors too. I hope that are fixed. It can be fixed later.

Regards,
Usman Mughal



[TOPIC: post.html]
#5

altafr

[GLOBAL: userInfoPane.html]
altafr
  • Contributor

  • 120 posts
  • Corona SDK

Hi,This is Meer,

 

I am facing same problem 

"Your app currently targets API level 25 and must target at least API level 26 to ensure it is built on the latest APIs optimized for security and performance.


From August 2018, new apps must target at least Android 8.0 (API level 26).
From November 2018, app updates must target Android 8.0 (API level 26).



Tip: Change your app's target API level. Learn how."

 

As i launched the app then play store sent following message

 

"Update the refused application

The application you recently sent has been disapproved because it violates the Google Play Program Policies (for developers) . If this was an update of the app, the previous version will still be available on Google Play."

 

Please help me, how to launch the app on play store.



[TOPIC: post.html]
#6

agramonte

[GLOBAL: userInfoPane.html]
agramonte
  • Contributor

  • 681 posts
  • Corona SDK

I just updated my app got the warning and the app was approved. Check the triangle in the console to figure out the reason it was rejected. I suspect it has nothing to do with the API level.



[TOPIC: post.html]
#7

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 24,315 posts
  • Corona Staff

I agree with @agramonte. This Android 8 message is just a reminder. You have something else preventing it from updating. It could be something as simple as missing a promo graphic, or not having an Age rating.

 

Rob




[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: security, performance, playstore, warnings, api support, api level 26