Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Cannot open Corona Live Server
Started by horacebury Apr 16 2018 11:20 PM

4 replies to this topic
daily
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

horacebury

[GLOBAL: userInfoPane.html]
horacebury
  • Corona Geek

  • 3,069 posts
  • Corona SDK

With the latest daily build I've noticed that the live server can't be opened automatically (at least, the first after daily build install) because gatekeeper blocks it, as it does the first time Corona Simulator is opened.

 

The issue can be resolved by opening it manually by choosing the menu option 'Show package contents' on the corona.app and navigating to Contents/Resources/Corona Live Server.app

 

Gatekeeper will ask for permission but only that one time. After that, Corona builds can auto-open the server.

 

I've not noticed this before - and I install *every* daily build. Anyone else?



[TOPIC: post.html]
#2

roaminggamer

[GLOBAL: userInfoPane.html]
roaminggamer
  • Corona Geek

  • 7,585 posts
  • Corona SDK

What is gatekeeper?  Is that an antivirus protection?  My avast AV does the same thing on Windows the first time I run any new program, including the first launch of a new livebuild.  PITA, but what can you do.

 

You're lucky to be just seeing this.  I have to deal with it on each first run of corona after updates.  :(



[TOPIC: post.html]
#3

horacebury

[GLOBAL: userInfoPane.html]
horacebury
  • Corona Geek

  • 3,069 posts
  • Corona SDK

The built-in Mac OS security: https://support.apple.com/en-gb/HT202491

 

I am again dealing with having to launch Corona simulator from a .command file, though :(



[TOPIC: post.html]
#4

SGS

[GLOBAL: userInfoPane.html]
SGS
  • Corona Geek

  • 2,107 posts
  • Corona SDK

Try BitDefender, it's what I use and doesn't exhibit that annoying behaviour.  That would drive me mad!



[TOPIC: post.html]
#5

horacebury

[GLOBAL: userInfoPane.html]
horacebury
  • Corona Geek

  • 3,069 posts
  • Corona SDK

Well, it's never been a problem until now. I don't know why the live server has suddenly started not playing nice with gatekeeper. I assume because of some key or cert which Corona Labs use to sign both Corona Sim and Live Server suddenly isn't the same.




[topic_controls]
[/topic_controls]